Read the docs

nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection

Why it matters now

EPSS 0.01233 69th percentileScored 2026-11-07
Fix Fixed ejs (npm): 2.5.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ejs (npm)before 2.5.52.5.5Patch availableGHSA-hwcf-pp87-7x6p
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ejs (npm) Vendor— Affected before 2.5.5 Fixed in 2.5.5 Patch available GHSA-hwcf-pp87-7x6p

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ejs:ejs:*:*:*:*:*:*:*:*before 2.5.5VulnerableEjs
  • cpe:2.3:a:ejs:ejs:*:*:*:*:*:*:*:* Versions before 2.5.5 Vulnerable ·Ejs

Remediation

  • Fix · GHSA-hwcf-pp87-7x6p ejs (npm) Fixed in 2.5.5 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Mobile Application Platform 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000188
  2. 2026-10-03 Alias added: GHSA-hwcf-pp87-7x6p

References

  • TI-2023-14035 ejs v3.1.9 is vulnerable to server-side template injection. CVSS 3.1CRITICAL 9.8
  • TI-2022-11633 The ejs (aka Embedded JavaScript templates) package 3.1.6 for Node.js allows server-side… CVSS 3.1CRITICAL 9.8
  • TI-2017-14544 nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak… CVSS 3.0CRITICAL 9.8
  • TI-2017-14510 nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak… CVSS 3.0HIGH 7.5

Sources