nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak…
Priority LOW 37CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in the ejs.renderFile()
Why it matters now
EPSS 0.02267 83rd percentileScored 2026-11-07
Fix Fixed ejs (npm): 2.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ejs (npm) | before 2.5.5 | 2.5.5 | Patch available | GHSA-6x77-rpqf-j6mw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ejs (npm) Vendor— Affected before 2.5.5 Fixed in 2.5.5 Patch available GHSA-6x77-rpqf-j6mw
Remediation
- Fix · GHSA-6x77-rpqf-j6mw ejs (npm) Fixed in 2.5.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Mobile Application Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000189
- 2026-10-03 Alias added: GHSA-6x77-rpqf-j6mw
References
Advisory 2
More Ejs vulnerabilities
- TI-2023-14035 ejs v3.1.9 is vulnerable to server-side template injection. CVSS 3.1CRITICAL 9.8
- TI-2022-11633 The ejs (aka Embedded JavaScript templates) package 3.1.6 for Node.js allows server-side… CVSS 3.1CRITICAL 9.8
- TI-2017-14544 nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak… CVSS 3.0CRITICAL 9.8
- TI-2017-14509 nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2017-1000189 · CVE Program
- CVE-2017-1000189 · NVD
- FIRST EPSS
- GHSA-6x77-rpqf-j6mw · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000189 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences