Read the docs

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to a…

Priority MEDIUM 40CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.

Summary

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to a login command which allowed impersonating any Jenkins user. The `login` command available in the remoting-based CLI stored the encrypted user name of the successfully authenticated user in a cache file used to authenticate further commands. Users with sufficient permission to create secrets in Jenkins, and download their encrypted values (e.g. with Job/Configure permission), were able to impersonate any other Jenkins user on the same instance.

Why it matters now

EPSS 0.01214 68th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.57, 2.46.2Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.50 to before 2.572.57Patch availableGHSA-r57f-7xw3-q2r9
—org.jenkins-ci.main:jenkins-core (Maven)before 2.46.22.46.2Patch availableGHSA-r57f-7xw3-q2r9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.50 to before 2.57 Fixed in 2.57 Patch available GHSA-r57f-7xw3-q2r9
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.46.2 Fixed in 2.46.2 Patch available GHSA-r57f-7xw3-q2r9

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 2.56VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.46.1VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 2.56 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.46.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-r57f-7xw3-q2r9 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.57 Advisory →
  • Fix · GHSA-r57f-7xw3-q2r9 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.46.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3Affected—

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000354
  2. 2026-10-03 Alias added: GHSA-r57f-7xw3-q2r9

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources