Read the docs

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an…

Priority MEDIUM 48CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 1 without a fix

Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-352.

Summary

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.

Why it matters now

EPSS 0.06957 94th percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 2.57, 2.46.2Red Hat: 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.50 to before 2.572.57Patch availableGHSA-85wq-pqhp-hmq6
—org.jenkins-ci.main:jenkins-core (Maven)before 2.46.22.46.2Patch availableGHSA-85wq-pqhp-hmq6
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.50 to before 2.57 Fixed in 2.57 Patch available GHSA-85wq-pqhp-hmq6
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.46.2 Fixed in 2.46.2 Patch available GHSA-85wq-pqhp-hmq6

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*up to 2.56VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.46.1VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions up to 2.56 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.46.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-85wq-pqhp-hmq6 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.57 Advisory →
  • Fix · GHSA-85wq-pqhp-hmq6 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.46.2 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Enterprise 3AffectedNo fix yet

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000356
  2. 2026-10-03 Alias added: GHSA-85wq-pqhp-hmq6

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources