Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins plugins. The fix for CVE-2012-6153 was backported to the version of commons-httpclient that is bundled in core and made available to plugins.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 2.73.2 | 2.73.2 | Patch available | GHSA-fq9f-9wv9-rfmg |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 2.74 to before 2.84 | 2.84 | Patch available | GHSA-fq9f-9wv9-rfmg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.73.2 Fixed in 2.73.2 Patch available GHSA-fq9f-9wv9-rfmg
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.74 to before 2.84 Fixed in 2.84 Patch available GHSA-fq9f-9wv9-rfmg
Remediation
- Fix · GHSA-fq9f-9wv9-rfmg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.73.2 Advisory →
- Fix · GHSA-fq9f-9wv9-rfmg org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.84 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat OpenShift Enterprise 3
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000396
- 2026-10-03 Alias added: GHSA-fq9f-9wv9-rfmg
References
More Jenkins vulnerabilities
- TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
- TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2017-1000396 · CVE Program
- CVE-2017-1000396 · NVD
- FIRST EPSS
- GHSA-fq9f-9wv9-rfmg · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000396 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences