Read the docs

The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api…

Priority LOW 22CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.

Summary

The Jenkins 2.73.1 and earlier, 2.83 and earlier remote API at /job/(job-name)/api contained information about upstream and downstream projects. This included information about tasks that the current user otherwise has no access to, e.g. due to lack of Item/Read permission. This has been fixed, and the API now only lists upstream and downstream projects that the current user has access to.

Why it matters now

EPSS 0.0083 57th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.73.2, 2.84

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)before 2.73.22.73.2Patch availableGHSA-p8x8-p473-mmmv
—org.jenkins-ci.main:jenkins-core (Maven)2.74 to before 2.842.84Patch availableGHSA-p8x8-p473-mmmv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 2.73.2 Fixed in 2.73.2 Patch available GHSA-p8x8-p473-mmmv
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.74 to before 2.84 Fixed in 2.84 Patch available GHSA-p8x8-p473-mmmv

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.73.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.83VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.73.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.83 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-p8x8-p473-mmmv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.73.2 Advisory →
  • Fix · GHSA-p8x8-p473-mmmv org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.84 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Enterprise 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000400
  2. 2026-10-03 Alias added: GHSA-p8x8-p473-mmmv

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources