MapProxy version 1.10.3 and older is vulnerable to a Cross Site Scripting attack in the…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
MapProxy version 1.10.3 and older is vulnerable to a Cross Site Scripting attack in the demo service resulting in possible information disclosure.
Why it matters now
EPSS 0.00783 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed MapProxy (PyPI): 1.11.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | MapProxy (PyPI) | before 1.11.1 | 1.11.1 | Patch available | GHSA-g4rw-82hq-8jpr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- MapProxy (PyPI) Vendor— Affected before 1.11.1 Fixed in 1.11.1 Patch available GHSA-g4rw-82hq-8jpr
Remediation
- Fix · GHSA-g4rw-82hq-8jpr MapProxy (PyPI) Fixed in 1.11.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000426
- 2026-10-03 Alias added: GHSA-g4rw-82hq-8jpr
References
Sources
- CVE-2017-1000426 · CVE Program
- CVE-2017-1000426 · NVD
- FIRST EPSS
- GHSA-g4rw-82hq-8jpr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences