Read the docs

marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.

Why it matters now

EPSS 0.01512 74th percentileScored 2026-11-07
Fix Fixed marked (npm): 0.3.7

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—marked (npm)before 0.3.70.3.7Patch availableGHSA-7px7-7xjx-hxm8
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • marked (npm) Vendor— Affected before 0.3.7 Fixed in 0.3.7 Patch available GHSA-7px7-7xjx-hxm8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:marked_project:marked:*:*:*:*:*:*:*:*up to 0.3.6Vulnerablemarkedjs
  • cpe:2.3:a:marked_project:marked:*:*:*:*:*:*:*:* Versions up to 0.3.6 Vulnerable ·markedjs

Remediation

  • Fix · GHSA-7px7-7xjx-hxm8 marked (npm) Fixed in 0.3.7 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000427
  2. 2026-10-03 Alias added: GHSA-7px7-7xjx-hxm8

References

  • TI-2026-30197 Marked: OOM Denial of Service via Infinite Recursion in marked Tokenizer CVSS 4.0HIGH 8.7
  • TI-2022-06057 Exponential catastrophic backtracking (ReDoS) in marked CVSS 3.1HIGH 7.5
  • TI-2022-06056 Cubic catastrophic backtracking (ReDoS) in marked CVSS 3.1HIGH 7.5
  • TI-2018-15336 Regular Expression Denial of Service (ReDoS) in markedjs/marked CVSS 4.0MEDIUM 6.9
  • TI-2015-07284 The marked package before 0.3.4 for Node.js allows attackers to cause a denial of service… CVSS 3.1HIGH 7.5
  • TI-2021-04406 Denial of Service in Marked CVSS 3.1HIGH 7.5
See all 10 →

Sources