eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.
Why it matters now
EPSS 0.00679 52nd percentileScored 2026-11-07
Fix Fixed ezsystems/ezpublish-legacy (Packagist): 5.4.10, 5.3.12.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ezsystems/ezpublish-legacy (Packagist) | 5.4.0 to before 5.4.10 | 5.4.10 | Patch available | GHSA-m98q-p5gq-q5ff |
| — | ezsystems/ezpublish-legacy (Packagist) | 5.3.0 to before 5.3.12.1 | 5.3.12.1 | Patch available | GHSA-m98q-p5gq-q5ff |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 5.4.0 to before 5.4.10 Fixed in 5.4.10 Patch available GHSA-m98q-p5gq-q5ff
- ezsystems/ezpublish-legacy (Packagist) Vendor— Affected 5.3.0 to before 5.3.12.1 Fixed in 5.3.12.1 Patch available GHSA-m98q-p5gq-q5ff
Remediation
- Fix · GHSA-m98q-p5gq-q5ff ezsystems/ezpublish-legacy (Packagist) Fixed in 5.4.10 Advisory →
- Fix · GHSA-m98q-p5gq-q5ff ezsystems/ezpublish-legacy (Packagist) Fixed in 5.3.12.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000431
- 2026-10-03 Alias added: GHSA-m98q-p5gq-q5ff
References
Other 3
- https://github.com/ezsystems/ezpublish-legacy/commit/c7174295fa0b9bd81bd4af908082464b0b80f278
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezpublish-legacy/CVE-2017-1000431.yaml
- https://web.archive.org/web/20210408035246/http://share.ez.no/community-project/security-advisories/ezsa-2017-005-xss-issue-in-search
More Ez Publish vulnerabilities
- TI-2007-04351 eZ publish before 3.8.9, and 3.9 before 3.9.3, does not properly check permissions on… CVSS 2.0HIGH 10.0
- TI-2005-04583 The default configuration of the forum package in eZ publish 3.5 before 3.5.5, 3.6 before… CVSS 2.0HIGH 9.4
- TI-2008-06532 The registration view (/user/register) in eZ Publish 3.5.6 and earlier, and possibly… CVSS 2.0HIGH 7.5
- TI-2012-01357 Unspecified vulnerability in ez Publish 4.1.4, 4.2, 4.3, 4.4, 4.5, and 4.6 has unknown… CVSS 2.0HIGH 7.5
- TI-2010-02562 Multiple SQL injection vulnerabilities in eZ Publish 3.7.0 through 4.2.0 allow remote… CVSS 2.0HIGH 7.5
- TI-2003-00291 Cross-site scripting (XSS) vulnerability in articleview.php for eZ publish 2.2 allows… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2017-1000431 · CVE Program
- CVE-2017-1000431 · NVD
- FIRST EPSS
- GHSA-m98q-p5gq-q5ff · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences