Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace
Why it matters now
EPSS 0.00516 44th percentileScored 2026-11-07
Fix Fixed passbolt/passbolt_api (Packagist): 1.6.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | passbolt/passbolt_api (Packagist) | before 1.6.5 | 1.6.5 | Patch available | GHSA-j2fp-9wp5-mg66 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- passbolt/passbolt_api (Packagist) Vendor— Affected before 1.6.5 Fixed in 1.6.5 Patch available GHSA-j2fp-9wp5-mg66
Remediation
- Fix · GHSA-j2fp-9wp5-mg66 passbolt/passbolt_api (Packagist) Fixed in 1.6.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000442
- 2026-10-03 Alias added: GHSA-j2fp-9wp5-mg66
References
Advisory 2
More Passbolt Api vulnerabilities
- TI-2024-22254 Passbolt API before 4.6.2 allows HTML injection in a URL parameter, resulting in custom… CVSS 3.1MEDIUM 4.3
- TI-2025-20637 Passbolt API before 5, if the server is misconfigured (with an incorrect installation… CVSS 4.0LOW 2.1
Sources
- CVE-2017-1000442 · CVE Program
- CVE-2017-1000442 · NVD
- FIRST EPSS
- GHSA-j2fp-9wp5-mg66 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences