Read the docs
TI-2024-22254 Aliases CVE-2024-33670GHSA-2pg6-vw9c-qhjv

Passbolt API before 4.6.2 allows HTML injection in a URL parameter, resulting in custom…

Priority LOW 21CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Passbolt API before 4.6.2 allows HTML injection in a URL parameter, resulting in custom content being displayed when a user visits the crafted URL. Although the injected content is not executed as JavaScript due to Content Security Policy (CSP) restrictions, it may still impact the appearance and user interaction of the page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00482 41st percentileScored 2026-11-07
Fix Fixed passbolt/passbolt_api (Packagist): 4.6.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—passbolt/passbolt_api (Packagist)before 4.6.24.6.2Patch availableGHSA-2pg6-vw9c-qhjv
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • passbolt/passbolt_api (Packagist) Vendor— Affected before 4.6.2 Fixed in 4.6.2 Patch available GHSA-2pg6-vw9c-qhjv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:passbolt:passbolt_api:*:*:*:*:*:*:*:*before 4.6.2VulnerablePassbolt
  • cpe:2.3:a:passbolt:passbolt_api:*:*:*:*:*:*:*:* Versions before 4.6.2 Vulnerable ·Passbolt

Remediation

  • Fix · GHSA-2pg6-vw9c-qhjv passbolt/passbolt_api (Packagist) Fixed in 4.6.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-33670
  2. 2026-10-03 Alias added: GHSA-2pg6-vw9c-qhjv

References

  • TI-2017-14656 Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace CVSS 3.0MEDIUM 5.4
  • TI-2025-20637 Passbolt API before 5, if the server is misconfigured (with an incorrect installation… CVSS 4.0LOW 2.1

Sources