Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic…
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Mautic version 2.1.0 - 2.11.0 is vulnerable to an inline JS XSS attack when using Mautic forms on a Mautic landing page using GET parameters to pre-populate the form.
Why it matters now
EPSS 0.00843 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed mautic/core (Packagist): 2.12.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mautic/core (Packagist) | 2.1.0 to before 2.12.0 | 2.12.0 | Patch available | GHSA-qjhr-c23f-w76q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mautic/core (Packagist) Vendor— Affected 2.1.0 to before 2.12.0 Fixed in 2.12.0 Patch available GHSA-qjhr-c23f-w76q
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.1.1:*:*:*:*:*:*:* | 2.1.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.2.1:*:*:*:*:*:*:* | 2.2.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.5.0:*:*:*:*:*:*:* | 2.5.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.6.0:*:*:*:*:*:*:* | 2.6.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.6.1:*:*:*:*:*:*:* | 2.6.1 | Vulnerable | Acquia |
- cpe:2.3:a:acquia:mautic:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.1.1:*:*:*:*:*:*:* Versions 2.1.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.2.1:*:*:*:*:*:*:* Versions 2.2.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.5.0:*:*:*:*:*:*:* Versions 2.5.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.6.0:*:*:*:*:*:*:* Versions 2.6.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.6.1:*:*:*:*:*:*:* Versions 2.6.1 Vulnerable ·Acquia
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:2.7.0:*:*:*:*:*:*:* | 2.7.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.7.1:*:*:*:*:*:*:* | 2.7.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.8.1:*:*:*:*:*:*:* | 2.8.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.8.2:*:*:*:*:*:*:* | 2.8.2 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.9.0:beta:*:*:*:*:*:* | 2.9.0 beta | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.9.1:*:*:*:*:*:*:* | 2.9.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.10.0:beta:*:*:*:*:*:* | 2.10.0 beta | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.10.1:*:*:*:*:*:*:* | 2.10.1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:2.11.0:beta:*:*:*:*:*:* | 2.11.0 beta | Vulnerable | Acquia |
| cpe:2.3:a:mautic:mautic:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | Mautic |
| cpe:2.3:a:mautic:mautic:2.9.2:*:*:*:*:*:*:* | 2.9.2 | Vulnerable | Mautic |
| cpe:2.3:a:mautic:mautic:2.10.0:*:*:*:*:*:*:* | 2.10.0 | Vulnerable | Mautic |
| cpe:2.3:a:mautic:mautic:2.11.0:*:*:*:*:*:*:* | 2.11.0 | Vulnerable | Mautic |
- cpe:2.3:a:acquia:mautic:2.7.0:*:*:*:*:*:*:* Versions 2.7.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.7.1:*:*:*:*:*:*:* Versions 2.7.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.8.1:*:*:*:*:*:*:* Versions 2.8.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.8.2:*:*:*:*:*:*:* Versions 2.8.2 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.9.0:beta:*:*:*:*:*:* Versions 2.9.0 beta Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.9.1:*:*:*:*:*:*:* Versions 2.9.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.10.0:beta:*:*:*:*:*:* Versions 2.10.0 beta Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.10.1:*:*:*:*:*:*:* Versions 2.10.1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:2.11.0:beta:*:*:*:*:*:* Versions 2.11.0 beta Vulnerable ·Acquia
- cpe:2.3:a:mautic:mautic:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Mautic
- cpe:2.3:a:mautic:mautic:2.9.2:*:*:*:*:*:*:* Versions 2.9.2 Vulnerable ·Mautic
- cpe:2.3:a:mautic:mautic:2.10.0:*:*:*:*:*:*:* Versions 2.10.0 Vulnerable ·Mautic
- cpe:2.3:a:mautic:mautic:2.11.0:*:*:*:*:*:*:* Versions 2.11.0 Vulnerable ·Mautic
Remediation
- Fix · GHSA-qjhr-c23f-w76q mautic/core (Packagist) Fixed in 2.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000488
- 2026-10-03 Alias added: GHSA-qjhr-c23f-w76q
References
Sources
- CVE-2017-1000488 · CVE Program
- CVE-2017-1000488 · NVD
- FIRST EPSS
- GHSA-qjhr-c23f-w76q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences