Read the docs

Mautic

Records49All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical7CVSS 9.0–10.0
CVSS high16CVSS 7.0–8.9

Exploited now

Mautic records in CISA KEV

No Mautic vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

49 records

TI-2022-09344 CVE-2022-25772 · GHSA-pjpc-87mp-4332

Cross-site scripting in Mautic

Priority HIGH 77

A cross-site scripting (XSS) vulnerability in the web tracking component of Mautic before 4.3.0 allows remote attackers to inject executable javascript

CVSS 3.1CRITICAL 9.6 Network No auth User interaction EPSS 0.63036 Published 2022-06-20 Fixed in 4.3.0 CWE-79
Priority MEDIUM 63

Mautic uses predictable page indices for unpublished landing pages, their content can be accessed by unauthenticated users under public preview URLs which could expose sensitive data.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00548 Published 2024-04-10 No fix listed CWE-425
Priority MEDIUM 58

Users with low privileges (all permissions deselected in the administrator permissions settings) can view certain pages that expose sensitive information such as company names, users' names and surnames, stage names, and…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00375 Published 2024-04-10 No fix listed CWE-284
Priority MEDIUM 46

This advisory addresses two critical security vulnerabilities present in Mautic versions before 5.2.3.

CVSS 3.1CRITICAL 9.9 Network Low privileges No interaction EPSS 0.01799 Published 2025-02-26 Fixed in 5.2.3 CWE-23
TI-2018-05847 CVE-2018-8092 · GHSA-29v9-2fpx-j5g9

Mautic before 2.13.0 allows CSV injection.

Priority MEDIUM 45

Mautic before 2.13.0 allows CSV injection.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.01633 Published 2018-04-18 Fixed in 2.13.0 CWE-1236
TI-2022-09342 CVE-2022-25769 · GHSA-mj6m-246h-9w56

Improper regex in htaccess file

Priority MEDIUM 42

ImpactThe default .htaccess file has some restrictions in the access to PHP files to only allow specific PHP files to be executed in the root of the application.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00507 Published 2024-09-18 Fixed in 3.3.5, 4.2.0 CWE-1284
Priority MEDIUM 42

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

CVSS 3.1CRITICAL 9.0 Network Low privileges User interaction EPSS 0.0062 Published 2024-09-17 Fixed in 4.4.12 CWE-80
Priority MEDIUM 40

SummaryA non privileged user can install and remove arbitrary packages via composer for a composer based installed, even if the flag in update settings for enable composer based update is unticked.

CVSS 4.0CRITICAL 9.0 Network Low privileges No interaction EPSS 0.00266 Published 2025-12-02 Fixed in 4.4.18, 5.2.9 +1 CWE-862
Priority MEDIUM 40

Summary Arbitrary files can be uploaded via the GrapesJS Builder, as the types of files that can be uploaded are not restricted.

CVSS 4.0HIGH 8.8 Network Low privileges User interaction EPSS 0.00451 Published 2025-12-02 Fixed in 4.4.18, 5.2.9 +1 CWE-434
Priority LOW 38

SummaryThis advisory addresses a SQL injection vulnerability in the API endpoint used for retrieving contact activities.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00329 Published 2026-02-24 Fixed in < 4.4.19 <5.2.10 <6.0.8 <7.0.1, 5.2.10 +2 CWE-89
TI-2021-09246 CVE-2021-27911 · GHSA-72hm-fx78-xwhc

XSS vulnerability on contacts view

Priority LOW 37

Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack through the contact's first or last name and triggered when viewing a contact's details page then clicking on the action drop down and hovering…

CVSS 3.1HIGH 8.3 Network No auth User interaction EPSS 0.00642 Published 2021-08-30 Fixed in 3.3.4, 4.0.0 CWE-79
Priority LOW 37

Insufficient sanitization / filtering allows for arbitrary JavaScript Injection in Mautic using the bounce management callback function.

CVSS 3.1HIGH 8.2 Network No auth User interaction EPSS 0.00699 Published 2021-08-30 Fixed in 3.3.4, 4.0.0 CWE-79
Priority LOW 36

Prior to the patched version, logged in users of Mautic are able to access areas of the application that they should be prevented from accessing.

CVSS 3.1HIGH 8.3 Network Low privileges No interaction EPSS 0.00396 Published 2024-09-18 Fixed in < 4.4.12, < 5.0.4 +2 CWE-276
Priority LOW 35

SummaryThis advisory addresses a security vulnerability in Mautic where unpublished page previews could be accessed by unauthenticated users and potentially indexed by search engines.

CVSS 3.1MEDIUM 6.5 Network No auth No interaction EPSS 0.00365 Published 2025-05-28 Fixed in < 6.0.2, <5.4.6 +4 CWE-1284
TI-2024-31436 CVE-2024-47053 · GHSA-8xv7-g2q3-fqgc

Improper Authorization in Reporting API

Priority LOW 35

This advisory addresses an authorization vulnerability in Mautic's HTTP Basic Authentication implementation.

CVSS 3.1HIGH 7.7 Network Low privileges No interaction EPSS 0.00738 Published 2025-02-26 Fixed in < 5.2.3, 5.2.3 CWE-285
TI-2021-09244 CVE-2021-27909 · GHSA-32hw-3pvh-vcvc

XSS vulnerability on password reset page

Priority LOW 35

For Mautic versions prior to 3.3.4/4.0.0, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code.

CVSS 3.1MEDIUM 6.3 Network No auth User interaction EPSS 0.04067 Published 2021-08-30 Fixed in 3.3.4, 4.0.0 CWE-79
TI-2022-09347 CVE-2022-25775 · GHSA-jj6w-2cqg-7p94

SQL Injection in dynamic Reports

Priority LOW 34

Prior to the patched version, logged in users of Mautic are vulnerable to an SQL injection vulnerability in the Reports bundle.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00593 Published 2024-09-18 Fixed in < 4.4.12, < 5.0.4 +2 CWE-89
TI-2022-09343 CVE-2022-25770 · GHSA-qf6m-6m4g-rmrc

Insufficient authentication in upgrade flow

Priority LOW 34

Mautic allows you to update the application via an upgrade script.

CVSS 3.1HIGH 7.8 Local No auth No interaction EPSS 0.00277 Published 2024-09-18 Fixed in < 4.4.13, < 5.1.1. +2 CWE-306
Priority LOW 34

A cross-site scripting (XSS) vulnerability in the installer component of Mautic before 4.3.0 allows admins to inject executable javascript

CVSS 3.1HIGH 7.6 Network High privileges User interaction EPSS 0.00477 Published 2022-06-01 Fixed in 4.3.0 CWE-79
Load more
Open these records in search →