Read the docs

A race condition during Jenkins 2.81 through 2.94 (inclusive); 2.89.1 startup could…

Priority LOW 38CWE-362Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

A race condition during Jenkins 2.81 through 2.94 (inclusive); 2.89.1 startup could result in the wrong order of execution of commands during initialization. This could in rare cases result in failure to initialize the setup wizard on the first startup. This resulted in multiple security-related settings not being set to their usual strict default.

Why it matters now

EPSS 0.01145 66th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.89.2, 2.95

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.81 to before 2.89.22.89.2Patch availableGHSA-r5x3-2446-hrp7
—org.jenkins-ci.main:jenkins-core (Maven)2.90 to before 2.952.95Patch availableGHSA-r5x3-2446-hrp7
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.81 to before 2.89.2 Fixed in 2.89.2 Patch available GHSA-r5x3-2446-hrp7
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.90 to before 2.95 Fixed in 2.95 Patch available GHSA-r5x3-2446-hrp7

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:*2.81 – 2.94VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:2.89.1:*:*:*:lts:*:*:*2.89.1VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:*:*:*:* Versions 2.81 – 2.94 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:2.89.1:*:*:*:lts:*:*:* Versions 2.89.1 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-r5x3-2446-hrp7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.89.2 Advisory →
  • Fix · GHSA-r5x3-2446-hrp7 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.95 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Enterprise 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000503
  2. 2026-10-03 Alias added: GHSA-r5x3-2446-hrp7

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources