Read the docs

A race condition during Jenkins 2.94 and earlier; 2.89.1 and earlier startup could result…

Priority LOW 37CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

A race condition during Jenkins 2.94 and earlier; 2.89.1 and earlier startup could result in the wrong order of execution of commands during initialization. There is a very short window of time after startup during which Jenkins may no longer show the 'Please wait while Jenkins is getting ready to work' message but Cross-Site Request Forgery (CSRF) protection may not yet be effective.

Why it matters now

EPSS 0.01016 63rd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.main:jenkins-core (Maven): 2.89.2, 2.95

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—org.jenkins-ci.main:jenkins-core (Maven)2.81 to before 2.89.22.89.2Patch availableGHSA-99hj-ppg3-2xwc
—org.jenkins-ci.main:jenkins-core (Maven)2.90 to before 2.952.95Patch availableGHSA-99hj-ppg3-2xwc
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.81 to before 2.89.2 Fixed in 2.89.2 Patch available GHSA-99hj-ppg3-2xwc
  • org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 2.90 to before 2.95 Fixed in 2.95 Patch available GHSA-99hj-ppg3-2xwc

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:*up to 2.89.1VulnerableJenkins
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:*up to 2.94VulnerableJenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* Versions up to 2.89.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* Versions up to 2.94 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-99hj-ppg3-2xwc org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.89.2 Advisory →
  • Fix · GHSA-99hj-ppg3-2xwc org.jenkins-ci.main:jenkins-core (Maven) Fixed in 2.95 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Enterprise 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000504
  2. 2026-10-03 Alias added: GHSA-99hj-ppg3-2xwc

References

  • TI-2024-15885 Path traversal in Jenkins KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
  • TI-2017-14573 Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an… KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
  • TI-2015-04472 The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote… KEVCVSS 3.1HIGH 7.5
  • TI-2016-07596 The remoting module in Jenkins before 2.32 and LTS before 2.19.3 allows remote attackers… CVSS 3.0CRITICAL 9.8
See all 293 →

Sources