Read the docs

Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in…

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Croogo version 2.3.1-17-g6f82e6c contains a Cross Site Scripting (XSS) vulnerability in Page name that can result in execution of javascript code.

Why it matters now

EPSS 0.00755 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed croogo/croogo (Packagist): 4.0.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—croogo/croogo (Packagist)before 4.0.04.0.0Patch availableGHSA-r4h9-gv2m-9x97
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • croogo/croogo (Packagist) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-r4h9-gv2m-9x97

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:croogo:croogo:2.3.1-17-g6f82e6c:*:*:*:*:*:*:*2.3.1-17-g6f82e6cVulnerableCroogo
  • cpe:2.3:a:croogo:croogo:2.3.1-17-g6f82e6c:*:*:*:*:*:*:* Versions 2.3.1-17-g6f82e6c Vulnerable ·Croogo

Remediation

  • Fix · GHSA-r4h9-gv2m-9x97 croogo/croogo (Packagist) Fixed in 4.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000510
  2. 2026-10-03 Alias added: GHSA-r4h9-gv2m-9x97

References

  • TI-2024-19484 An issue in croogo v.3.0.2 allows an attacker to perform Host header injection via the feed.rss component. CVSS 3.1CRITICAL 9.1
  • TI-2024-28584 A path traversal vulnerability in Croogo CMS 4.0.7 allows remote attackers to read… CVSS 3.1MEDIUM 6.5
  • TI-2021-20199 A Remote Code Execution (RCE) vulnerability exists in Croogo 3.0.2via… CVSS 3.1HIGH 8.8
  • TI-2014-07043 Multiple cross-site scripting (XSS) vulnerabilities in Croogo before 2.1.0 allow remote… CVSS 2.0MEDIUM 4.3
  • TI-2015-00948 Cross-site scripting (XSS) vulnerability in the administrative backend in Croogo before… CVSS 2.0MEDIUM 4.3
  • TI-2019-15009 Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies. CVSS 3.1MEDIUM 4.8
See all 11 →

Sources