Read the docs

Improper input validation in Koji

Priority LOW 35CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Koji 1.13.0 does not properly validate SCM paths, allowing an attacker to work around blacklisted paths for build submission.

Why it matters now

EPSS 0.01184 67th percentileScored 2026-11-07
Fix Fixed koji (PyPI): 1.15.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Koji ProjectKoji1.13.0—No fix listedCNA
—koji (PyPI)before 1.15.01.15.0Patch availableGHSA-vwp5-w4rq-g4cc
  • Koji VendorKoji Project Affected 1.13.0 Fixed in — No fix listed CNA
  • koji (PyPI) Vendor— Affected before 1.15.0 Fixed in 1.15.0 Patch available GHSA-vwp5-w4rq-g4cc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:koji_project:koji:1.13.0:*:*:*:*:*:*:*1.13.0VulnerableKoji Project
  • cpe:2.3:a:koji_project:koji:1.13.0:*:*:*:*:*:*:* Versions 1.13.0 Vulnerable ·Koji Project

Remediation

  • Fix · GHSA-vwp5-w4rq-g4cc koji (PyPI) Fixed in 1.15.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1002153
  2. 2026-10-03 Alias added: GHSA-vwp5-w4rq-g4cc

References

  • TI-2018-16131 Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability… CVSS 3.0CRITICAL 9.1
  • TI-2019-12765 Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation. CVSS 3.1MEDIUM 6.5

Sources