Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability…
Priority MEDIUM 43CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Koji version 1.12, 1.13, 1.14 and 1.15 contain an incorrect access control vulnerability resulting in arbitrary filesystem read/write access. This vulnerability has been fixed in versions 1.12.1, 1.13.1, 1.14.1 and 1.15.1.
Why it matters now
EPSS 0.01658 76th percentileScored 2026-11-07
Fix Fixed koji (PyPI): 1.15.1, 1.14.1, 1.13.1 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | koji (PyPI) | 1.15 to before 1.15.1 | 1.15.1 | Patch available | GHSA-6mww-xvh7-fq4f |
| — | koji (PyPI) | 1.14 to before 1.14.1 | 1.14.1 | Patch available | GHSA-6mww-xvh7-fq4f |
| — | koji (PyPI) | 1.13 to before 1.13.1 | 1.13.1 | Patch available | GHSA-6mww-xvh7-fq4f |
| — | koji (PyPI) | 1.12 to before 1.12.1 | 1.12.1 | Patch available | GHSA-6mww-xvh7-fq4f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- koji (PyPI) Vendor— Affected 1.15 to before 1.15.1 Fixed in 1.15.1 Patch available GHSA-6mww-xvh7-fq4f
- koji (PyPI) Vendor— Affected 1.14 to before 1.14.1 Fixed in 1.14.1 Patch available GHSA-6mww-xvh7-fq4f
- koji (PyPI) Vendor— Affected 1.13 to before 1.13.1 Fixed in 1.13.1 Patch available GHSA-6mww-xvh7-fq4f
- koji (PyPI) Vendor— Affected 1.12 to before 1.12.1 Fixed in 1.12.1 Patch available GHSA-6mww-xvh7-fq4f
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:koji_project:koji:1.12.0:*:*:*:*:*:*:* | 1.12.0 | Vulnerable | Koji Project |
| cpe:2.3:a:koji_project:koji:1.13.0:*:*:*:*:*:*:* | 1.13.0 | Vulnerable | Koji Project |
| cpe:2.3:a:koji_project:koji:1.14.0:*:*:*:*:*:*:* | 1.14.0 | Vulnerable | Koji Project |
| cpe:2.3:a:koji_project:koji:1.15.0:*:*:*:*:*:*:* | 1.15.0 | Vulnerable | Koji Project |
- cpe:2.3:a:koji_project:koji:1.12.0:*:*:*:*:*:*:* Versions 1.12.0 Vulnerable ·Koji Project
- cpe:2.3:a:koji_project:koji:1.13.0:*:*:*:*:*:*:* Versions 1.13.0 Vulnerable ·Koji Project
- cpe:2.3:a:koji_project:koji:1.14.0:*:*:*:*:*:*:* Versions 1.14.0 Vulnerable ·Koji Project
- cpe:2.3:a:koji_project:koji:1.15.0:*:*:*:*:*:*:* Versions 1.15.0 Vulnerable ·Koji Project
Remediation
- Fix · GHSA-6mww-xvh7-fq4f koji (PyPI) Fixed in 1.15.1 Advisory →
- Fix · GHSA-6mww-xvh7-fq4f koji (PyPI) Fixed in 1.14.1 Advisory →
- Fix · GHSA-6mww-xvh7-fq4f koji (PyPI) Fixed in 1.13.1 Advisory →
- Fix · GHSA-6mww-xvh7-fq4f koji (PyPI) Fixed in 1.12.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1002150
- 2026-10-03 Alias added: GHSA-6mww-xvh7-fq4f
References
Advisory 4
More Koji Project Koji vulnerabilities
- TI-2019-12765 Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation. CVSS 3.1MEDIUM 6.5
- TI-2017-14760 Improper input validation in Koji CVSS 3.1HIGH 7.5
Sources
- CVE-2018-1002150 · CVE Program
- CVE-2018-1002150 · NVD
- FIRST EPSS
- GHSA-6mww-xvh7-fq4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences