Path traversal in Javo Spot WordPress theme lets attackers read files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
Javo Spot theme for WordPress before 3.0.0 contains a path traversal flaw (CWE-22) in the fn parameter of its jvfrm_spot_get_json AJAX action. An unauthenticated remote attacker can read arbitrary files on the server through a crafted GET request. Shadowserver Foundation first observed exploitation on 2023-10-19, and a public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
Description from the CNA
Javo Spot theme for WordPress before 3.0.0 contains a path traversal vulnerability that allows unauthenticated attackers to read arbitrary files via the fn parameter of the jvfrm_spot_get_json AJAX action. Attackers can send GET requests to /wp-admin/admin-ajax.php with fn set to ../../wp-config.php to retrieve database credentials and secret keys. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| javothemes | Javo Spot | before 3.0.0 | 3.0.0 | Patch available | CNA |
- Javo Spot Vendorjavothemes Affected before 3.0.0 Fixed in 3.0.0 Patch available CNA
Remediation
Update Javo Spot to version 3.0.0 or later, which fixes the flaw.
Written with Claude Haiku 5.5 from the sources below · 2026-11-05
- Fix · CNA Javo Spot (Javo Themes) Fixed in 3.0.0
Timeline
- 2026-10-22 Threatist record created from CVE-2017-20287
- 2026-10-22 Alias added: GHSA-f9g9-m55p-h787
- 2026-10-23 Priority changed: MEDIUM → LOW
- 2026-10-28 CISA SSVC decision points changed
- 2026-10-28 Priority changed: LOW → HIGH
- 2026-10-29 EPSS moved to the 50th–90th percentile
References
More javothemes vulnerabilities
- TI-2025-00137 Javo Core <= 3.0.0.080 - Unauthenticated Privilege Escalation in ajax_signup CVSS 3.1CRITICAL 9.8
- TI-2025-37477 WordPress Javo Core Plugin <= 3.0.0.266 - Cross Site Request Forgery (CSRF) Vulnerability CVSS 3.1HIGH 8.8
- TI-2025-36530 WordPress Javo Core plugin <= 3.0.0.529 - Arbitrary Content Deletion vulnerability CVSS 3.1HIGH 7.5
- TI-2025-35855 WordPress Javo Core Plugin <= 3.0.0.266 - Broken Access Control Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2025-37434 WordPress Javo Core plugin <= 3.0.0.266 - Arbitrary Code Execution vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2017-20287 · CVE Program
- CVE-2017-20287 · NVD
- FIRST EPSS
- GHSA-f9g9-m55p-h787 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences