Cross-site scripting in Red Hat Moodle
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions. Unauthenticated users can trigger custom messages to admin via paypal enrol script. Paypal IPN callback script should only send error emails to admin after request origin was verified, otherwise admin email can be spammed.
Why it matters now
EPSS 0.0141 72nd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.11, 3.2.8, 3.3.5 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Moodle | 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.11 | 3.1.11 | Patch available | GHSA-v9xq-vh72-chr4 |
| — | moodle/moodle (Packagist) | 3.2 to before 3.2.8 | 3.2.8 | Patch available | GHSA-v9xq-vh72-chr4 |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.5 | 3.3.5 | Patch available | GHSA-v9xq-vh72-chr4 |
| — | moodle/moodle (Packagist) | 3.4 to before 3.4.2 | 3.4.2 | Patch available | GHSA-v9xq-vh72-chr4 |
- Moodle VendorRed Hat Affected 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.11 Fixed in 3.1.11 Patch available GHSA-v9xq-vh72-chr4
- moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.8 Fixed in 3.2.8 Patch available GHSA-v9xq-vh72-chr4
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.5 Fixed in 3.3.5 Patch available GHSA-v9xq-vh72-chr4
- moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.2 Fixed in 3.4.2 Patch available GHSA-v9xq-vh72-chr4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 3.0.10; 3.1 – 3.1.10; 3.2 – 3.2.7; 3.3 – 3.3.4; 3.4.0 – 3.4.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.0.10; 3.1 – 3.1.10; 3.2 – 3.2.7; 3.3 – 3.3.4; 3.4.0 – 3.4.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-v9xq-vh72-chr4 moodle/moodle (Packagist) Fixed in 3.1.11 Advisory →
- Fix · GHSA-v9xq-vh72-chr4 moodle/moodle (Packagist) Fixed in 3.2.8 Advisory →
- Fix · GHSA-v9xq-vh72-chr4 moodle/moodle (Packagist) Fixed in 3.3.5 Advisory →
- Fix · GHSA-v9xq-vh72-chr4 moodle/moodle (Packagist) Fixed in 3.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1081
- 2026-10-03 Alias added: GHSA-v9xq-vh72-chr4
References
More Red Hat vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
- TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
- TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-1081 · CVE Program
- CVE-2018-1081 · NVD
- FIRST EPSS
- GHSA-v9xq-vh72-chr4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences