Ansible Tower before version 3.2.4 has a flaw in the management of system and…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation, Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-266 and CWE-521.
Summary
Ansible Tower before version 3.2.4 has a flaw in the management of system and organization administrators that allows for privilege escalation. System administrators that are members of organizations can have their passwords reset by organization administrators, allowing organization administrators access to the entire system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Ansible Tower | before 3.2.4 | 3.2.4 | Patch available | CNA |
- Ansible Tower VendorRed Hat Affected before 3.2.4 Fixed in 3.2.4 Patch available CNA
Remediation
Red Hat 2 advisories
- RHSA-2018:1972 Released 2018-06-25 · Red Hat rating ImportantRed Hat CloudForms security, bug fix, and enhancement update
- CloudForms Management Engine 5.8 ansible-2.4.4.0-1.el7ae, ansible-tower-server-3.1.7-1.el7at, ansible-tower-setup-3.1.7-1.el7at +7
- RHSA-2018:1328 Released 2018-05-07 · Red Hat rating ImportantCloudForms 4.6.2 bug fix and enhancement update
- CloudForms Management Engine 5.9 ansible-2.4.4.0-1.el7ae, ansible-doc-2.4.4.0-1.el7ae, ansible-tower-3.2.4-1.el7at +29
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5.8 | Fixed | RHSA-2018:1972 |
| CloudForms Management Engine 5.9 | Fixed | RHSA-2018:1328 |
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1101
- 2026-10-03 Alias added: GHSA-hfwp-5v2g-2vvc
References
More Red Hat Ansible Tower vulnerabilities
- TI-2018-12447 Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2… CVSS 3.0CRITICAL 9.8
- TI-2015-07641 _XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2018-09275 The get_cookies function in soup-cookie-jar.c in libsoup 2.63.2 allows attackers to have… CVSS 3.0CRITICAL 9.8
- TI-2018-00980 Improper input validation in [UNKNOWN] python CVSS 3.1HIGH 7.5
- TI-2018-16030 Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect… CVSS 3.1HIGH 8.8
- TI-2018-10539 An issue was discovered in kwajd_read_headers in mspack/kwajd.c in libmspack before… CVSS 3.0HIGH 8.8
Sources
- CVE-2018-1101 · CVE Program
- CVE-2018-1101 · NVD
- FIRST EPSS
- GHSA-hfwp-5v2g-2vvc · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1101 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences