Priority CRITICAL 87
Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive "git clone" of a superproj…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.97356 · Published 2018-10-06 · Partial fix CWE-88
Priority MEDIUM 51
_XcursorThemeInherits in library.c in libXcursor before 1.1.15 allows remote attackers to cause denial of service or potentially code execution via a one-byte heap overflow.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05677 · Published 2018-08-01 · Partial fix CWE-119
Priority MEDIUM 49
The get_cookies function in soup-cookie-jar.c in libsoup 2.63.2 allows attackers to have unspecified impact via an empty hostname.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.04188 · Published 2018-07-05 · Partial fix CWE-125
Priority MEDIUM 47
python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in pop3lib's apop() method.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.05039 · Published 2018-06-18 · Partial fix CWE-20
Priority MEDIUM 45
Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains a Incorrect Access Control vulnerability in SSH server that can result in RCE.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.04407 · Published 2018-10-08 · Partial fix · 2.4.2, 2.3.3 +3 CWE-863
Priority MEDIUM 45
An issue was discovered in kwajd_read_headers in mspack/kwajd.c in libmspack before 0.7alpha.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.03757 · Published 2018-07-28 · Fixed CWE-787
Priority MEDIUM 44
Ansible Tower before version 3.3.3 does not set a secure channel as it is using the default insecure configuration channel settings for messaging celery workers from RabbitMQ.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0111 · Published 2019-01-03 · No fix listed CWE-311
Priority MEDIUM 44
An issue was discovered in mspack/chmd.c in libmspack before 0.7alpha.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.0361 · Published 2018-07-28 · Fixed CWE-193
Priority MEDIUM 43
Ansible Tower through version 3.2.3 has a vulnerability that allows users only with access to define variables for a job template to execute arbitrary code on the Tower server.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0247 · Published 2018-05-02 · Fixed CWE-20
Priority MEDIUM 40
Ansible Tower before versions 3.1.8 and 3.2.6 is vulnerable to cross-site request forgery (CSRF) in awx/api/authentication.py.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.00863 · Published 2018-08-22 · No fix listed CWE-352
Priority MEDIUM 40
python before versions 2.7.15, 3.4.9, 3.5.6rc1, 3.6.5rc1 and 3.7.0 is vulnerable to catastrophic backtracking in the difflib.IS_LINE_JUNK method.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.04742 · Published 2018-06-19 · Partial fix CWE-20
Priority MEDIUM 40
A flaw was found in Ansible Tower's interface before 3.1.5 and 3.2.0 with SCM repositories.
CVSS 3.0HIGH 8.4· Network · High privileges · User interaction · EPSS 0.01707 · Published 2018-07-27 · Partial fix CWE-20
Priority LOW 39
A flaw was found in Ansible Tower, versions 3.6.x before 3.6.2 and 3.5.x before 3.5.3, where enabling RabbitMQ manager by setting it with '-e rabbitmq_enable_manager=true' exposes the RabbitMQ management interface public…
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.01534 · Published 2019-12-19 · Fixed CWE-1188
Priority LOW 38
A flaw was found in ansible-tower where the default installation is vulnerable to job isolation escape.
CVSS 3.1HIGH 8.8· Local · Low privileges · No interaction · EPSS 0.00248 · Published 2022-08-25 · Fixed CWE-552
Priority LOW 37
A flaw was found in the Ansible Engine 2.9.18, where sensitive info is not masked by default and is not protected by the no_log feature when using the sub-option feature of the basic.py module.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02043 · Published 2021-04-29 · Partial fix · 2.10.6rc1, 2.9.18rc1 +1 CWE-200
Priority LOW 36
A vulnerability was found in Ansible Tower before 3.6.1 where an attacker with low privilege could retrieve usernames and passwords credentials from the new RHSM saved in plain text into the database at '/api/v2/config'…
CVSS 3.1HIGH 8.4· Local · Low privileges · No interaction · EPSS 0.00237 · Published 2019-11-26 · Fixed CWE-312
Priority LOW 36
A privilege escalation flaw was found in the Ansible Tower.
CVSS 3.0HIGH 8.0· Adjacent network · Low privileges · No interaction · EPSS 0.00635 · Published 2018-09-11 · No fix listed CWE-266
Priority LOW 35
An issue was discovered in mspack/chmd.c in libmspack before 0.7alpha.
CVSS 3.0MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.03705 · Published 2018-07-28 · Fixed CWE-20
Priority LOW 35
An issue was discovered in mspack/chmd.c in libmspack before 0.7alpha.
CVSS 3.0MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.0327 · Published 2018-07-28 · Fixed CWE-193
Priority LOW 35
Ansible Tower before version 3.2.4 has a flaw in the management of system and organization administrators that allows for privilege escalation.
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01942 · Published 2018-05-02 · Fixed in 3.2.4 CWE-266
Priority LOW 34
A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled,…
CVSS 3.1HIGH 7.9· Local · Low privileges · User interaction · EPSS 0.00331 · Published 2020-03-24 · Partial fix · 2.7.17, 2.8.11 +1 CWE-362
Priority LOW 34
A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination…
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00365 · Published 2020-03-09 · Partial fix · 2.8.9, 2.9.6 +1 CWE-22
Priority LOW 34
When running Tower before 3.4.3 on OpenShift or Kubernetes, application credentials are exposed to playbook job runs via environment variables.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01266 · Published 2019-03-28 · Fixed CWE-214
Priority LOW 34
Ansible "User" module leaks any data which is passed on as a parameter to ssh-keygen.
CVSS 3.0HIGH 7.8· Local · No auth · User interaction · EPSS 0.00362 · Published 2018-10-23 · Partial fix · 2.7.1, 2.6.7 +1 CWE-214
Priority LOW 34
Poppler through 0.62 contains an out of bounds read vulnerability due to an incorrect memory access that is not mapped in its memory space, as demonstrated by pdfunite.
CVSS 3.0MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.0311 · Published 2018-07-25 · Partial fix CWE-125
Load more