Information disclosure in Cloud Foundry Foundation cf-release versions prior to v285…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3, the SessionID is logged in audit event logs. An attacker can use the SessionID to impersonate a logged-in user.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3 | Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3 | — | No fix listed | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | before 4.5.5 | 4.5.5 | Patch available | GHSA-xg5v-696h-c3vr |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.6.0 to before 4.7.4 | 4.7.4 | Patch available | GHSA-xg5v-696h-c3vr |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.8.0 to before 4.8.3 | 4.8.3 | Patch available | GHSA-xg5v-696h-c3vr |
- Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3 Vendor— Affected Cloud Foundry Foundation cf-release versions prior to v285; cf-deployment versions prior to v1.7; UAA 4.5.x versions prior to 4.5.5, 4.8.x versions prior to 4.8.3, and 4.7.x versions prior to 4.7.4; and UAA-release 45.7.x versions prior to 45.7, 52.7.x versions prior to 52.7, and 53.3.x versions prior to 53.3 Fixed in — No fix listed CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected before 4.5.5 Fixed in 4.5.5 Patch available GHSA-xg5v-696h-c3vr
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.6.0 to before 4.7.4 Fixed in 4.7.4 Patch available GHSA-xg5v-696h-c3vr
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.8.0 to before 4.8.3 Fixed in 4.8.3 Patch available GHSA-xg5v-696h-c3vr
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* | 4.5.0 to before 4.5.5; 4.7.0 to before 4.7.4; 4.8.0 to before 4.8.3 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:45.7:*:*:*:*:*:*:* | 45.7 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:52.7:*:*:*:*:*:*:* | 52.7 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:53.3:*:*:*:*:*:*:* | 53.3 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_cf-release:*:*:*:*:*:*:*:* | before 285 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:pivotal_software:cloud_foundry_cf-deployment:*:*:*:*:*:*:*:* | before 1.7 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* Versions 4.5.0 to before 4.5.5; 4.7.0 to before 4.7.4; 4.8.0 to before 4.8.3 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:45.7:*:*:*:*:*:*:* Versions 45.7 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:52.7:*:*:*:*:*:*:* Versions 52.7 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa-release:53.3:*:*:*:*:*:*:* Versions 53.3 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_cf-release:*:*:*:*:*:*:*:* Versions before 285 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:pivotal_software:cloud_foundry_cf-deployment:*:*:*:*:*:*:*:* Versions before 1.7 Vulnerable ·Spring by Pivotal
Remediation
- Fix · GHSA-xg5v-696h-c3vr org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.5.5 Advisory →
- Fix · GHSA-xg5v-696h-c3vr org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.7.4 Advisory →
- Fix · GHSA-xg5v-696h-c3vr org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.8.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1192
- 2026-10-03 Alias added: GHSA-xg5v-696h-c3vr
References
Advisory 2
Other 5
- https://github.com/cloudfoundry/uaa/commit/1f529fcb43fd200cab10587e889343ef1683c6e6
- https://github.com/cloudfoundry/uaa/commit/599391fe5d564c7e4860b8a6ec17cda872a822a3
- https://github.com/cloudfoundry/uaa/commit/a61bfabbad22f646ecf1f00016b448b26a60daf
- https://github.com/cloudfoundry/uaa
- https://www.cloudfoundry.org/blog/cve-2018-1192
More Spring by Pivotal Cloud Foundry Cf-deployment vulnerabilities
- TI-2020-04445 CredHub does not properly enable TLS for MySQL database connections CVSS 3.1HIGH 7.4
Sources
- CVE-2018-1192 · CVE Program
- CVE-2018-1192 · NVD
- FIRST EPSS
- GHSA-xg5v-696h-c3vr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences