Information disclosure in Apache Storm
Priority LOW 32CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Apache Storm version 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier expose a vulnerability that could allow a user to impersonate another user when communicating with some Storm Daemons.
Why it matters now
EPSS 0.01413 72nd percentileScored 2026-11-07
Fix Fixed org.apache.storm:storm-core (Maven): 1.1.3, 1.2.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Storm | Apache Storm 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier | — | No fix listed | CNA |
| — | org.apache.storm:storm-core (Maven) | before 1.1.3 | 1.1.3 | Patch available | GHSA-q35p-chc6-7x57 |
| — | org.apache.storm:storm-core (Maven) | 1.2.0 to before 1.2.2 | 1.2.2 | Patch available | GHSA-q35p-chc6-7x57 |
- Apache Storm VendorApache Affected Apache Storm 1.0.6 and earlier, 1.2.1 and earlier, and version 1.1.2 and earlier Fixed in — No fix listed CNA
- org.apache.storm:storm-core (Maven) Vendor— Affected before 1.1.3 Fixed in 1.1.3 Patch available GHSA-q35p-chc6-7x57
- org.apache.storm:storm-core (Maven) Vendor— Affected 1.2.0 to before 1.2.2 Fixed in 1.2.2 Patch available GHSA-q35p-chc6-7x57
Remediation
- Fix · GHSA-q35p-chc6-7x57 org.apache.storm:storm-core (Maven) Fixed in 1.1.3 Advisory →
- Fix · GHSA-q35p-chc6-7x57 org.apache.storm:storm-core (Maven) Fixed in 1.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1332
- 2026-10-03 Alias added: GHSA-q35p-chc6-7x57
References
Advisory 2
More Apache Storm vulnerabilities
- TI-2021-15907 Shell Command Injection Vulnerability in Nimbus Thrift Server CVSS 3.1CRITICAL 9.8
- TI-2021-17787 Unsafe Pre-Authentication Deserialization In Workers CVSS 3.1CRITICAL 9.8
- TI-2015-02819 The UI daemon in Apache Storm 0.10.0 before 0.10.0-beta1 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2018-08436 Deserialization of untrusted data in Apache Storm CVSS 3.0CRITICAL 9.8
- TI-2017-07179 It was found that under some situations and configurations of Apache Storm 1.x before… CVSS 3.0HIGH 8.8
- TI-2018-01232 In Apache Storm 0.10.0 through 0.10.2, 1.0.0 through 1.0.6, 1.1.0 through 1.1.2, and… CVSS 3.0HIGH 8.8
Sources
- CVE-2018-1332 · CVE Program
- CVE-2018-1332 · NVD
- FIRST EPSS
- GHSA-q35p-chc6-7x57 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences