Read the docs
TI-2018-02720 Aliases CVE-2018-3722GHSA-9g9w-hmvj-5h57

merge-deep node module before 3.0.1 suffers from a Modification of Assumed-Immutable Data…

Priority MEDIUM 42CWE-471Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

merge-deep node module before 3.0.1 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.

Why it matters now

EPSS 0.02004 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed merge-deep node module (HackerOne): 3.0.1merge-deep (npm): 3.0.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
HackerOnemerge-deep node modulebefore 3.0.13.0.1Patch availableCNA
—merge-deep (npm)before 3.0.13.0.1Patch availableGHSA-9g9w-hmvj-5h57
  • merge-deep node module VendorHackerOne Affected before 3.0.1 Fixed in 3.0.1 Patch available CNA
  • merge-deep (npm) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-9g9w-hmvj-5h57

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:merge-deep_project:merge-deep:*:*:*:*:*:node.js:*:*before 3.0.1VulnerableMerge-deep Project
  • cpe:2.3:a:merge-deep_project:merge-deep:*:*:*:*:*:node.js:*:* Versions before 3.0.1 Vulnerable ·Merge-deep Project

Remediation

  • Fix · CNA merge-deep node module (HackerOne) Fixed in 3.0.1
  • Fix · GHSA-9g9w-hmvj-5h57 merge-deep (npm) Fixed in 3.0.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-3722
  2. 2026-10-03 Alias added: GHSA-9g9w-hmvj-5h57

References

  • TI-2021-08386 The merge-deep library before 3.0.3 for Node.js can be tricked into overwriting… CVSS 3.1CRITICAL 9.8

Sources