Command injection in HackerOne pdfinfojs
Priority MEDIUM 50CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on the victim's machine.
Why it matters now
EPSS 0.04853 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pdfinfojs (npm): 0.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | pdfinfojs | up to 0.3.6 | — | No fix listed | CNA |
| — | pdfinfojs (npm) | before 0.4.1 | 0.4.1 | Patch available | GHSA-3pxp-6963-46r9 |
- pdfinfojs VendorHackerOne Affected up to 0.3.6 Fixed in — No fix listed CNA
- pdfinfojs (npm) Vendor— Affected before 0.4.1 Fixed in 0.4.1 Patch available GHSA-3pxp-6963-46r9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pdfinfojs_project:pdfinfojs:*:*:*:*:*:node.js:*:* | up to 0.3.6 | Vulnerable | Pdfinfojs Project |
- cpe:2.3:a:pdfinfojs_project:pdfinfojs:*:*:*:*:*:node.js:*:* Versions up to 0.3.6 Vulnerable ·Pdfinfojs Project
Remediation
- Fix · GHSA-3pxp-6963-46r9 pdfinfojs (npm) Fixed in 0.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3746
- 2026-10-03 Alias added: GHSA-3pxp-6963-46r9
References
Sources
- CVE-2018-3746 · CVE Program
- CVE-2018-3746 · NVD
- FIRST EPSS
- GHSA-3pxp-6963-46r9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences