Some versions of BIND can improperly permit recursive query service to unauthorized clients
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
Change #4777 (introduced in October 2017) introduced an unforeseen issue in releases which were issued after that date, affecting which clients are permitted to make recursive queries to a BIND nameserver. The intended (and documented) behavior is that if an operator has not specified a value for the "allow-recursion" setting, it SHOULD default to one of the following: none, if "recursion no;" is set in named.conf; a value inherited from the "allow-query-cache" or "allow-query" settings IF "recursion yes;" (the default for that setting) AND match lists are explicitly set for "allow-query-cache" or "allow-query" (see the BIND9 Administrative Reference Manual section 6.2 for more details); or the intended default of "allow-recursion {localhost; localnets;};" if "recursion yes;" is in effect and no values are explicitly set for "allow-query-cache" or "allow-query". However, because of the regression introduced by change #4777, it is possible when "recursion yes;" is in effect and no match list values are provided for "allow-query-cache" or "allow-query" for the setting of "allow-recursion" to inherit a setting of all hosts from the "allow-query" setting default, improperly permitting recursion to all clients. Affects BIND 9.9.12, 9.10.7, 9.11.3, 9.12.0->9.12.1-P2, the development release 9.13.0, and also releases 9.9.12-S1, 9.10.7-S1, 9.11.3-S1, and 9.11.3-S2 from BIND 9 Supported Preview Edition.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | 9.9.12, 9.10.7, 9.11.3, 9.12.0->9.12.1-P2, the development release 9.13.0, and also releases 9.9.12-S1, 9.10.7-S1, 9.11.3-S1, and 9.11.3-S2 from BIND 9 Supported Preview Edition. | — | No fix listed | CNA |
- BIND 9 VendorISC Affected 9.9.12, 9.10.7, 9.11.3, 9.12.0->9.12.1-P2, the development release 9.13.0, and also releases 9.9.12-S1, 9.10.7-S1, 9.11.3-S1, and 9.11.3-S2 from BIND 9 Supported Preview Edition. Fixed in — No fix listed CNA
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.9.12:*:*:*:*:*:*:* | 9.9.12 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.12:s1:*:*:*:*:*:* | 9.9.12 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.7:*:*:*:*:*:*:* | 9.10.7 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.7:s1:*:*:*:*:*:* | 9.10.7 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.3:*:*:*:*:*:*:* | 9.11.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.3:s1:*:*:*:*:*:* | 9.11.3 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.3:s2:*:*:*:*:*:* | 9.11.3 s2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.0:*:*:*:*:*:*:* | 9.12.0 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.0:a1:*:*:*:*:*:* | 9.12.0 a1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.0:b1:*:*:*:*:*:* | 9.12.0 b1 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:9.9.12:*:*:*:*:*:*:* Versions 9.9.12 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.12:s1:*:*:*:*:*:* Versions 9.9.12 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.7:*:*:*:*:*:*:* Versions 9.10.7 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.7:s1:*:*:*:*:*:* Versions 9.10.7 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.3:*:*:*:*:*:*:* Versions 9.11.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.3:s1:*:*:*:*:*:* Versions 9.11.3 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.3:s2:*:*:*:*:*:* Versions 9.11.3 s2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.0:*:*:*:*:*:*:* Versions 9.12.0 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.0:a1:*:*:*:*:*:* Versions 9.12.0 a1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.0:b1:*:*:*:*:*:* Versions 9.12.0 b1 Vulnerable ·ISC
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:9.12.0:b2:*:*:*:*:*:* | 9.12.0 b2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.0:rc1:*:*:*:*:*:* | 9.12.0 rc1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.0:rc3:*:*:*:*:*:* | 9.12.0 rc3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.1:*:*:*:*:*:*:* | 9.12.1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.1:p1:*:*:*:*:*:* | 9.12.1 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.1:p2:*:*:*:*:*:* | 9.12.1 p2 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.13.0:*:*:*:*:*:*:* | 9.13.0 | Vulnerable | ISC |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
- cpe:2.3:a:isc:bind:9.12.0:b2:*:*:*:*:*:* Versions 9.12.0 b2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.0:rc1:*:*:*:*:*:* Versions 9.12.0 rc1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.0:rc3:*:*:*:*:*:* Versions 9.12.0 rc3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.1:*:*:*:*:*:*:* Versions 9.12.1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.1:p1:*:*:*:*:*:* Versions 9.12.1 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.1:p2:*:*:*:*:*:* Versions 9.12.1 p2 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.13.0:*:*:*:*:*:*:* Versions 9.13.0 Vulnerable ·ISC
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
Remediation
No fixed version listed by the sources yet.
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
ISC BIND 9 — GLSA-201903-13
3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-04147 A flaw in the "deny-answer-aliases" feature can cause an assertion failure in namedPriority HIGH 67
- TI-2018-04148 Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentationPriority LOW 35
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5738
- 2026-10-03 Alias added: GHSA-cg2m-4gq8-j388
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2018-5738 · CVE Program
- CVE-2018-5738 · NVD
- FIRST EPSS
- GHSA-cg2m-4gq8-j388 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5738 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences