Read the docs
TI-2018-04148 Aliases CVE-2018-5741GHSA-ghpp-72v8-mpmv

Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation

Priority LOW 35CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Partial Red Hat: 8 fixed, 1 without a fix

Attack profile from CVSS 3.0 · CNA. Fix status from CNA and Red Hat. Impact type from CWE-863.

Summary

To provide fine-grained controls over the ability to use Dynamic DNS (DDNS) to update records in a zone, BIND 9 provides a feature called update-policy. Various rules can be configured to limit the types of updates that can be performed by a client, depending on the key used when sending the update request. Unfortunately, some rule types were not initially documented, and when documentation for them was added to the Administrator Reference Manual (ARM) in change #3112, the language that was added to the ARM at that time incorrectly described the behavior of two rule types, krb5-subdomain and ms-subdomain. This incorrect documentation could mislead operators into believing that policies they had configured were more restrictive than they actually were. This affects BIND versions prior to BIND 9.11.5 and BIND 9.12.3.

Why it matters now

EPSS 0.03451 89th percentileScored 2026-11-07
Fix Partial Red Hat: 1 advisoryRed Hat: 8 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 9BIND 9 Versions prior to BIND 9.11.5 and BIND 9.12.3—No fix listedCNA
  • BIND 9 VendorISC Affected BIND 9 Versions prior to BIND 9.11.5 and BIND 9.12.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*before 9.11.5; 9.12.0 to before 9.12.3VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions before 9.11.5; 9.12.0 to before 9.12.3 Vulnerable ·ISC

Remediation

Red Hat 1 advisory

  • RHSA-2019:2057 Released 2019-08-06 · Red Hat rating Moderate
    bind security, bug fix, and enhancement update
    • Red Hat Enterprise Linux Client (v. 7) bind-32:9.11.4-9.P2.el7, bind-export-libs-32:9.11.4-9.P2.el7, bind-libs-32:9.11.4-9.P2.el7 +3
    • Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.11.4-9.P2.el7, bind-chroot-32:9.11.4-9.P2.el7, bind-devel-32:9.11.4-9.P2.el7 +8
    • Red Hat Enterprise Linux ComputeNode (v. 7) bind-32:9.11.4-9.P2.el7, bind-export-libs-32:9.11.4-9.P2.el7, bind-libs-32:9.11.4-9.P2.el7 +3
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.11.4-9.P2.el7, bind-chroot-32:9.11.4-9.P2.el7, bind-devel-32:9.11.4-9.P2.el7 +8
    • Red Hat Enterprise Linux Server (v. 7) bind-32:9.11.4-9.P2.el7, bind-chroot-32:9.11.4-9.P2.el7, bind-export-libs-32:9.11.4-9.P2.el7 +11
    • Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.11.4-9.P2.el7, bind-devel-32:9.11.4-9.P2.el7.ppc, bind-export-devel-32:9.11.4-9.P2.el7 +7
    • Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.11.4-9.P2.el7, bind-chroot-32:9.11.4-9.P2.el7, bind-export-libs-32:9.11.4-9.P2.el7 +7
    • Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.11.4-9.P2.el7, bind-export-devel-32:9.11.4-9.P2.el7, bind-lite-devel-32:9.11.4-9.P2.el7 +3

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ISC BIND 9 — GLSA-201903-13

    3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2018-04147 A flaw in the "deny-answer-aliases" feature can cause an assertion failure in namedPriority HIGH 67
    • TI-2018-04145 Some versions of BIND can improperly permit recursive query service to unauthorized clientsPriority MEDIUM 46

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux Client (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux ComputeNode (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2019:2057
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2019:2057
Not affected: 3 products
  • Red Hat Enterprise Linux 5
  • Red Hat Enterprise Linux 8
  • Red Hat Virtualization 4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-5741
  2. 2026-10-03 Alias added: GHSA-ghpp-72v8-mpmv

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources