An assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keys
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 10 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-327.
Summary
"managed-keys" is a feature which allows a BIND resolver to automatically maintain the keys used by trust anchors which operators configure for use in DNSSEC validation. Due to an error in the managed-keys feature it is possible for a BIND server which uses managed-keys to exit due to an assertion failure if, during key rollover, a trust anchor's keys are replaced with keys which use an unsupported algorithm. Versions affected: BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2018-5745.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ISC | BIND 9 | BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2018-5745. | — | No fix listed | CNA |
- BIND 9 VendorISC Affected BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P1, 9.12.0 -> 9.12.3-P1, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2018-5745. Fixed in — No fix listed CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* | 9.9.0 – 9.10.7; 9.11.0 – 9.11.4; 9.12.0 – 9.12.2; 9.13.0 – 9.13.6 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:* | 9.9.3 s1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.7:-:*:*:*:*:*:* | 9.10.7 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:* | 9.10.8 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:* | 9.11.5 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:* | 9.11.5 p1 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.11.5:s3:*:*:*:*:*:* | 9.11.5 s3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.3:-:*:*:*:*:*:* | 9.12.3 | Vulnerable | ISC |
| cpe:2.3:a:isc:bind:9.12.3:p1:*:*:*:*:*:* | 9.12.3 p1 | Vulnerable | ISC |
- cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.9.0 – 9.10.7; 9.11.0 – 9.11.4; 9.12.0 – 9.12.2; 9.13.0 – 9.13.6 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:* Versions 9.9.3 s1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.7:-:*:*:*:*:*:* Versions 9.10.7 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:* Versions 9.10.8 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:* Versions 9.11.5 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:* Versions 9.11.5 p1 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.11.5:s3:*:*:*:*:*:* Versions 9.11.5 s3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.3:-:*:*:*:*:*:* Versions 9.12.3 Vulnerable ·ISC
- cpe:2.3:a:isc:bind:9.12.3:p1:*:*:*:*:*:* Versions 9.12.3 p1 Vulnerable ·ISC
Remediation
Red Hat 2 advisories
- RHSA-2020:1061 Released 2020-03-31 · Red Hat rating Moderatebind security and bug fix update
- Red Hat Enterprise Linux Client (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
- Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
- Red Hat Enterprise Linux ComputeNode (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
- Red Hat Enterprise Linux Server (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +11
- Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7.ppc, bind-export-devel-32:9.11.4-16.P2.el7 +7
- Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +7
- Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-export-devel-32:9.11.4-16.P2.el7, bind-lite-devel-32:9.11.4-16.P2.el7 +3
- RHSA-2019:3552 Released 2019-11-05 · Red Hat rating Lowbind security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 8) bind-32:9.11.4-26.P2.el8, bind-chroot-32:9.11.4-26.P2.el8, bind-devel-32:9.11.4-26.P2.el8 +12
- Red Hat Enterprise Linux BaseOS (v. 8) bind-32:9.11.4-26.P2.el8, bind-export-devel-32:9.11.4-26.P2.el8, bind-export-libs-32:9.11.4-26.P2.el8
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
ISC BIND 9 — RHSA-2019:3552
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2019-04530 Zone transfer controls for writable DLZ zones were not effectivePriority LOW 31
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2019:3552 |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2019:3552 |
| Red Hat Enterprise Linux Client (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux ComputeNode (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux ComputeNode Optional (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux Server Optional (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2020:1061 |
| Red Hat Enterprise Linux Workstation Optional (v. 7) | Fixed | RHSA-2020:1061 |
Not affected: 1 product
- Red Hat Enterprise Linux 5
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5745
- 2026-10-03 Alias added: GHSA-p5r3-98fj-vgcv
References
More ISC Bind vulnerabilities
- TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
- TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
- TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
- TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
- TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
- TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
Sources
- CVE-2018-5745 · CVE Program
- CVE-2018-5745 · NVD
- FIRST EPSS
- GHSA-p5r3-98fj-vgcv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-5745 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences