Read the docs
TI-2019-04530 Aliases CVE-2019-6465GHSA-5hgv-gr6q-xvqx

Zone transfer controls for writable DLZ zones were not effective

Priority LOW 31CWE-732Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · None · None
Fix status
Partial Red Hat: 10 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat.

Summary

Controls for zone transfers may not be properly applied to Dynamically Loadable Zones (DLZs) if the zones are writable Versions affected: BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P2, 9.12.0 -> 9.12.3-P2, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2019-6465.

Why it matters now

EPSS 0.03979 90th percentileScored 2026-11-07
Fix Partial Red Hat: 2 advisoriesRed Hat: 10 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ISCBIND 9BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P2, 9.12.0 -> 9.12.3-P2, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2019-6465.—No fix listedCNA
  • BIND 9 VendorISC Affected BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P2, 9.12.0 -> 9.12.3-P2, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2019-6465. Fixed in — No fix listed CNA

CPE configurations NVD · 12

CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*9.9.0 – 9.10.7; 9.11.0 – 9.11.4; 9.12.0 – 9.12.2; 9.13.0 – 9.13.6VulnerableISC
cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:*9.9.3 s1VulnerableISC
cpe:2.3:a:isc:bind:9.10.8:-:*:*:*:*:*:*9.10.8VulnerableISC
cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:*9.10.8 p1VulnerableISC
cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:*9.11.5VulnerableISC
cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:*9.11.5 p1VulnerableISC
cpe:2.3:a:isc:bind:9.11.5:p2:*:*:*:*:*:*9.11.5 p2VulnerableISC
cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:*9.11.5 s3VulnerableISC
cpe:2.3:a:isc:bind:9.12.3:-:*:*:*:*:*:*9.12.3VulnerableISC
cpe:2.3:a:isc:bind:9.12.3:p1:*:*:*:*:*:*9.12.3 p1VulnerableISC
  • cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:* Versions 9.9.0 – 9.10.7; 9.11.0 – 9.11.4; 9.12.0 – 9.12.2; 9.13.0 – 9.13.6 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.9.3:s1:*:*:*:*:*:* Versions 9.9.3 s1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.8:-:*:*:*:*:*:* Versions 9.10.8 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.10.8:p1:*:*:*:*:*:* Versions 9.10.8 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.5:-:*:*:*:*:*:* Versions 9.11.5 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.5:p1:*:*:*:*:*:* Versions 9.11.5 p1 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.5:p2:*:*:*:*:*:* Versions 9.11.5 p2 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.11.5:s3:*:*:supported_preview:*:*:* Versions 9.11.5 s3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.12.3:-:*:*:*:*:*:* Versions 9.12.3 Vulnerable ·ISC
  • cpe:2.3:a:isc:bind:9.12.3:p1:*:*:*:*:*:* Versions 9.12.3 p1 Vulnerable ·ISC
Show 2 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:isc:bind:9.12.3:p2:*:*:*:*:*:*9.12.3 p2VulnerableISC
cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:*8.0VulnerableRed Hat
  • cpe:2.3:a:isc:bind:9.12.3:p2:*:*:*:*:*:* Versions 9.12.3 p2 Vulnerable ·ISC
  • cpe:2.3:o:redhat:enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Red Hat

Remediation

Red Hat 2 advisories

  • RHSA-2020:1061 Released 2020-03-31 · Red Hat rating Moderate
    bind security and bug fix update
    • Red Hat Enterprise Linux Client (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
    • Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
    • Red Hat Enterprise Linux ComputeNode (v. 7) bind-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7, bind-libs-32:9.11.4-16.P2.el7 +3
    • Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7 +8
    • Red Hat Enterprise Linux Server (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +11
    • Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-devel-32:9.11.4-16.P2.el7.ppc, bind-export-devel-32:9.11.4-16.P2.el7 +7
    • Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.11.4-16.P2.el7, bind-chroot-32:9.11.4-16.P2.el7, bind-export-libs-32:9.11.4-16.P2.el7 +7
    • Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.11.4-16.P2.el7, bind-export-devel-32:9.11.4-16.P2.el7, bind-lite-devel-32:9.11.4-16.P2.el7 +3
  • RHSA-2019:3552 Released 2019-11-05 · Red Hat rating Low
    bind security and bug fix update
    • Red Hat Enterprise Linux AppStream (v. 8) bind-32:9.11.4-26.P2.el8, bind-chroot-32:9.11.4-26.P2.el8, bind-devel-32:9.11.4-26.P2.el8 +12
    • Red Hat Enterprise Linux BaseOS (v. 8) bind-32:9.11.4-26.P2.el8, bind-export-devel-32:9.11.4-26.P2.el8, bind-export-libs-32:9.11.4-26.P2.el8

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Advisory ·

    ISC BIND 9 — RHSA-2019:3552

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2018-04152 An assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed-keysPriority LOW 27

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 5AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 6AffectedNo fix planned: Will not fix
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2019:3552
Red Hat Enterprise Linux BaseOS (v. 8)Fixed RHSA-2019:3552
Red Hat Enterprise Linux Client (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Client Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux ComputeNode (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux ComputeNode Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Server (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Server Optional (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Workstation (v. 7)Fixed RHSA-2020:1061
Red Hat Enterprise Linux Workstation Optional (v. 7)Fixed RHSA-2020:1061

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-6465
  2. 2026-10-03 Alias added: GHSA-5hgv-gr6q-xvqx
  3. 2026-10-20 EPSS moved to the 90th–95th percentile

References

  • TI-2015-04610 Assertion failure in ISC BIND named via TKEY queries KEVCVSS 3.1HIGH 7.5
  • TI-2023-27571 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related… CVSS 3.1HIGH 7.5
  • TI-2021-07476 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack CVSS 3.1CRITICAL 9.8
  • TI-2023-27773 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance… CVSS 3.1HIGH 7.5
  • TI-2020-06910 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c CVSS 3.1HIGH 7.5
  • TI-2016-02320 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x… CVSS 3.0HIGH 7.5
See all 192 →

Sources