An unauthenticated remote command execution exists in Aruba ClearPass Policy Manager on…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
An unauthenticated remote command execution exists in Aruba ClearPass Policy Manager on linked devices. The ClearPass OnConnect feature permits administrators to link other network devices into ClearPass for the purpose of collecting enhanced information about connected endpoints. A defect in the API could allow a remote attacker to execute arbitrary commands on one of the linked devices. This vulnerability is only applicable if credentials for devices have been supplied to ClearPass under Configuration -> Network -> Devices -> CLI Settings. Resolution: Fixed in 6.7.5 and 6.6.10-hotfix.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Hewlett Packard Enterprise | Aruba ClearPass Policy Manager | ClearPass 6.7.x prior to 6.7.5, ClearPass 6.6.10 and earlier without hotfix applied | — | No fix listed | CNA |
- Aruba ClearPass Policy Manager VendorHewlett Packard Enterprise Affected ClearPass 6.7.x prior to 6.7.5, ClearPass 6.6.10 and earlier without hotfix applied Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:arubanetworks:clearpass_policy_manager:*:*:*:*:*:*:*:* | before 6.6.10; 6.7.0 to before 6.7.5 | Vulnerable | Arubanetworks |
- cpe:2.3:a:arubanetworks:clearpass_policy_manager:*:*:*:*:*:*:*:* Versions before 6.6.10; 6.7.0 to before 6.7.5 Vulnerable ·Arubanetworks
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7066
- 2026-10-03 Alias added: GHSA-xmmx-hv46-7cxp
References
More Hewlett Packard Enterprise vulnerabilities
- TI-2017-03639 Improper handling of exceptional conditions in Apache Struts KEVCVSS 3.1CRITICAL 9.8
- TI-2015-02747 Heap-based buffer overflow in Adobe Flash Player before 13.0.0.296 and 14.x through 18.x… KEVCVSS 3.1CRITICAL 9.8
- TI-2013-04219 HP ProCurve Manager (PCM) 3.20 and 4.0, PCM+ 3.20 and 4.0, Identity Driven Manager (IDM)… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2005-02634 HP OpenView Network Node Manager 6.2 through 7.50 allows remote attackers to execute… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-07113 Integer overflow in Adobe Flash Player before 18.0.0.324 and 19.x and 20.x before… KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2018-7066 · CVE Program
- CVE-2018-7066 · NVD
- FIRST EPSS
- GHSA-xmmx-hv46-7cxp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences