An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0"…
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of pre-release status). It might allow local users to bypass intended filesystem access restrictions because ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | npm (npm) | before 5.7.1 | 5.7.1 | Patch available | GHSA-ph34-pc88-72gc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- npm (npm) Vendor— Affected before 5.7.1 Fixed in 5.7.1 Patch available GHSA-ph34-pc88-72gc
Remediation
- Fix · GHSA-ph34-pc88-72gc npm (npm) Fixed in 5.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7408
- 2026-10-03 Alias added: GHSA-ph34-pc88-72gc
References
More Npmjs Npm vulnerabilities
- TI-2021-19484 The npm ci command in npm 7.x and 8.x through 8.1.3 proceeds with an installation even if… CVSS 3.1CRITICAL 9.8
- TI-2022-11785 npm packing does not respect root-level ignore files in workspaces CVSS 3.1HIGH 7.5
- TI-2019-12556 Unauthorized File Access in npm CLI before before version 6.13.3 CVSS 3.1HIGH 8.1
- TI-2016-03362 The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before… CVSS 3.1HIGH 7.5
- TI-2019-12555 Unauthorized File Access in npm CLI before before version 6.13.3 CVSS 3.1HIGH 7.7
- TI-2019-12557 Arbitrary File Overwrite in npm CLI CVSS 3.1HIGH 7.7
Sources
- CVE-2018-7408 · CVE Program
- CVE-2018-7408 · NVD
- FIRST EPSS
- GHSA-ph34-pc88-72gc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences