Path traversal in Apache Hadoop
Priority MEDIUM 48CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Apache Hadoop 3.1.0, 3.0.0-alpha to 3.0.2, 2.9.0 to 2.9.1, 2.8.0 to 2.8.4, 2.0.0-alpha to 2.7.6, 0.23.0 to 0.23.11 is exploitable via the zip slip vulnerability in places that accept a zip file.
Why it matters now
EPSS 0.06734 93rd percentileScored 2026-11-07
Fix Fixed org.apache.hadoop:hadoop-main (Maven): 3.1.1, 3.0.3, 2.9.2 +2Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Hadoop | Apache Hadoop 3.1.0, 3.0.0-alpha to 3.0.2, 2.9.0 to 2.9.1, 2.8.0 to 2.8.4, 2.0.0-alpha to 2.7.6, 0.23.0 to 0.23.11 | — | No fix listed | CNA |
| — | org.apache.hadoop:hadoop-main (Maven) | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-6x48-j4x4-cqw3 |
| — | org.apache.hadoop:hadoop-main (Maven) | 3.0.0 to before 3.0.3 | 3.0.3 | Patch available | GHSA-6x48-j4x4-cqw3 |
| — | org.apache.hadoop:hadoop-main (Maven) | 2.9.0 to before 2.9.2 | 2.9.2 | Patch available | GHSA-6x48-j4x4-cqw3 |
| — | org.apache.hadoop:hadoop-main (Maven) | 2.8.0 to before 2.8.5 | 2.8.5 | Patch available | GHSA-6x48-j4x4-cqw3 |
| — | org.apache.hadoop:hadoop-main (Maven) | before 2.7.7 | 2.7.7 | Patch available | GHSA-6x48-j4x4-cqw3 |
- Apache Hadoop VendorApache Affected Apache Hadoop 3.1.0, 3.0.0-alpha to 3.0.2, 2.9.0 to 2.9.1, 2.8.0 to 2.8.4, 2.0.0-alpha to 2.7.6, 0.23.0 to 0.23.11 Fixed in — No fix listed CNA
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-6x48-j4x4-cqw3
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected 3.0.0 to before 3.0.3 Fixed in 3.0.3 Patch available GHSA-6x48-j4x4-cqw3
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected 2.9.0 to before 2.9.2 Fixed in 2.9.2 Patch available GHSA-6x48-j4x4-cqw3
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected 2.8.0 to before 2.8.5 Fixed in 2.8.5 Patch available GHSA-6x48-j4x4-cqw3
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected before 2.7.7 Fixed in 2.7.7 Patch available GHSA-6x48-j4x4-cqw3
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* | 0.23.0 – 0.23.11; 2.0.0 – 2.7.6; 2.8.0 – 2.8.4; 2.9.0 – 2.9.1; 3.0.0 – 3.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* | 3.0.0 alpha1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* | 3.0.0 alpha2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* | 3.0.0 alpha3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* | 3.0.0 alpha4 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:beta1:*:*:*:*:*:* | 3.0.0 beta1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* Versions 0.23.0 – 0.23.11; 2.0.0 – 2.7.6; 2.8.0 – 2.8.4; 2.9.0 – 2.9.1; 3.0.0 – 3.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* Versions 3.0.0 alpha1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* Versions 3.0.0 alpha2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* Versions 3.0.0 alpha3 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* Versions 3.0.0 alpha4 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:beta1:*:*:*:*:*:* Versions 3.0.0 beta1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-6x48-j4x4-cqw3 org.apache.hadoop:hadoop-main (Maven) Fixed in 3.1.1 Advisory →
- Fix · GHSA-6x48-j4x4-cqw3 org.apache.hadoop:hadoop-main (Maven) Fixed in 3.0.3 Advisory →
- Fix · GHSA-6x48-j4x4-cqw3 org.apache.hadoop:hadoop-main (Maven) Fixed in 2.9.2 Advisory →
- Fix · GHSA-6x48-j4x4-cqw3 org.apache.hadoop:hadoop-main (Maven) Fixed in 2.8.5 Advisory →
- Fix · GHSA-6x48-j4x4-cqw3 org.apache.hadoop:hadoop-main (Maven) Fixed in 2.7.7 Advisory →
Red Hat 1 advisory
- RHSA-2019:3892 Released 2019-11-14 · Red Hat rating ImportantRed Hat Fuse 7.5.0 security update
- Red Hat Fuse 7.5.0
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Fuse 7.5.0 | Fixed | RHSA-2019:3892 |
Not affected: 2 products
- Red Hat JBoss Fuse 6
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8009
- 2026-10-03 Alias added: GHSA-6x48-j4x4-cqw3
References
Advisory 4
Other 14
- [hadoop-user] 20181122 CVE-2018-8009: Apache Hadoop distributed cache archive vulnerability
- [lucene-solr-user] 20190104 Re: SOLR v7 Security Issues Caused Denial of Use - Sonatype Application Composition Report
- [druid-commits] 20201008 [druid] branch master updated: Suppress CVE-2018-11765 for hadoop dependencies (#10485)
- [druid-commits] 20201008 [druid] branch 0.20.0 updated: Suppress CVE-2018-11765 for hadoop dependencies (#10485) (#10492)
- https://github.com/apache/hadoop/commit/12258c7cff8d32710fbd8b9088a930e3ce27432
- https://github.com/apache/hadoop/commit/45a1c680c276c4501402f7bc4cebcf85a6fbc7f
- https://github.com/apache/hadoop/commit/65e55097da2bb3f2fbdf9ba1946da25fe58bec9
- https://github.com/apache/hadoop/commit/6a4ae6f6eeed1392a4828a5721fa1499f65bdde
- https://github.com/apache/hadoop/commit/fc4c20fc3469674cb584a4fb98bac7e3c2277c9
- https://github.com/apache/hadoop
- https://lists.apache.org/thread.html/708d94141126eac03011144a971a6411fcac16d9c248d1d535a39451@%3Csolr-user.lucene.apache.org%3E
- https://lists.apache.org/thread.html/a1c227745ce30acbcf388c5b0cc8423e8bf495d619cd0fa973f7f38d@%3Cuser.hadoop.apache.org%3E
- https://lists.apache.org/thread.html/r4dddf1705dbedfa94392913b2dad1cd2d1d89040facd389eea0b3510@%3Ccommits.druid.apache.org%3E
- https://lists.apache.org/thread.html/rb21df54a4e39732ce653d2aa5672e36a792b59eb6717f2a06bb8d02a@%3Ccommits.druid.apache.org%3E
More Apache Hadoop vulnerabilities
- TI-2019-12818 Connect2id Nimbus JOSE+JWT before v7.9 can throw various uncaught exceptions while… CVSS 3.1CRITICAL 9.8
- TI-2022-09898 Arbitrary file write in FileUtil#unpackEntries on Windows CVSS 3.1CRITICAL 9.8
- TI-2022-08881 Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar CVSS 3.1CRITICAL 9.8
- TI-2021-15353 Heap buffer overflow in libhdfs native library CVSS 3.1CRITICAL 9.8
- TI-2017-11489 Information disclosure in Apache Hadoop CVSS 3.0CRITICAL 9.8
- TI-2016-02585 Information disclosure in Apache Hadoop CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-8009 · CVE Program
- CVE-2018-8009 · NVD
- FIRST EPSS
- GHSA-6x48-j4x4-cqw3 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-8009 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences