io/mongo/parser.py in Eve (aka pyeve) before 0.7.5 allows remote attackers to execute…
Priority MEDIUM 51CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
io/mongo/parser.py in Eve (aka pyeve) before 0.7.5 allows remote attackers to execute arbitrary code via Code Injection in the where parameter.
Why it matters now
EPSS 0.06252 93rd percentileScored 2026-11-07
Fix Fixed eve (PyPI): 0.7.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | eve (PyPI) | before 0.7.5 | 0.7.5 | Patch available | GHSA-8jxq-75rw-fhj9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- eve (PyPI) Vendor— Affected before 0.7.5 Fixed in 0.7.5 Patch available GHSA-8jxq-75rw-fhj9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-eve:eve:*:*:*:*:*:*:*:* | before 0.7.5 | Vulnerable | Python-eve |
- cpe:2.3:a:python-eve:eve:*:*:*:*:*:*:*:* Versions before 0.7.5 Vulnerable ·Python-eve
Remediation
- Fix · GHSA-8jxq-75rw-fhj9 eve (PyPI) Fixed in 0.7.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8097
- 2026-10-03 Alias added: GHSA-8jxq-75rw-fhj9
References
Advisory 3
Sources
- CVE-2018-8097 · CVE Program
- CVE-2018-8097 · NVD
- FIRST EPSS
- GHSA-8jxq-75rw-fhj9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences