Incorrect permission assignment in [UNKNOWN] podman
Priority MEDIUM 40CWE-250Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-250.
Summary
It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.
Why it matters now
EPSS 0.00878 59th percentileScored 2026-11-07
Fix Fixed github.com/containers/podman (Go): 0.6.1Red Hat: 1 advisory
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | podman | podman 0.6.1 | — | No fix listed | CNA |
| — | github.com/containers/podman (Go) | before 0.6.1 | 0.6.1 | Patch available | GHSA-wp7w-vx86-vj9h |
- podman Vendor[UNKNOWN] Affected podman 0.6.1 Fixed in — No fix listed CNA
- github.com/containers/podman (Go) Vendor— Affected before 0.6.1 Fixed in 0.6.1 Patch available GHSA-wp7w-vx86-vj9h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpod_project:libpod:*:*:*:*:*:*:*:* | before 0.6.1 | Vulnerable | Libpod Project |
- cpe:2.3:a:libpod_project:libpod:*:*:*:*:*:*:*:* Versions before 0.6.1 Vulnerable ·Libpod Project
Remediation
- Fix · GHSA-wp7w-vx86-vj9h github.com/containers/podman (Go) Fixed in 0.6.1 Advisory →
Red Hat 1 advisory
- RHSA-2018:2037 Released 2018-06-26 · Red Hat rating Moderatepodman security update
- Red Hat Enterprise Linux 7 Extras podman-0.6.1-3.git3e0ff12.el7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 Extras | Fixed | RHSA-2018:2037 |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10856
- 2026-10-03 Alias added: GHSA-wp7w-vx86-vj9h
References
More Libpod Project Libpod vulnerabilities
- TI-2019-07473 Path traversal in podman CVSS 3.1HIGH 7.2
- TI-2020-01670 A flaw was discovered in Podman where it incorrectly allows containers when created to… CVSS 3.1MEDIUM 5.9
- TI-2019-07534 Insufficiently protected credentials in containers/image CVSS 3.1MEDIUM 5.9
- TI-2019-13437 An issue was discovered in Podman in libpod before 1.6.0. CVSS 3.1MEDIUM 5.5
Sources
- CVE-2018-10856 · CVE Program
- CVE-2018-10856 · NVD
- FIRST EPSS
- GHSA-wp7w-vx86-vj9h · GitHub Advisory Database · CC BY 4.0
- CVE-2018-10856 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences