A weakness was found in postgresql-jdbc before version 42.2.5.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 without a fix
Attack profile from CVSS 3.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
A weakness was found in postgresql-jdbc before version 42.2.5. It was possible to provide an SSL Factory and not check the host name if a host name verifier was not provided to the driver. This could lead to a condition where a man-in-the-middle attacker could masquerade as a trusted server by providing a certificate for the wrong host, as long as it was signed by a trusted CA.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | PostgreSQL | 42.2.5 | — | No fix listed | CNA |
| — | org.postgresql:pgjdbc-aggregate (Maven) | before 42.2.5 | 42.2.5 | Patch available | GHSA-568q-9fw5-28wf |
- PostgreSQL Vendor[UNKNOWN] Affected 42.2.5 Fixed in — No fix listed CNA
- org.postgresql:pgjdbc-aggregate (Maven) Vendor— Affected before 42.2.5 Fixed in 42.2.5 Patch available GHSA-568q-9fw5-28wf
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:postgresql:postgresql_jdbc_driver:*:*:*:*:*:*:*:* | before 42.2.5 | Vulnerable | PostgreSQL |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
- cpe:2.3:a:postgresql:postgresql_jdbc_driver:*:*:*:*:*:*:*:* Versions before 42.2.5 Vulnerable ·PostgreSQL
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
Remediation
- Fix · GHSA-568q-9fw5-28wf org.postgresql:pgjdbc-aggregate (Maven) Fixed in 42.2.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Virtualization 4 | Affected | No fix planned: Will not fix |
Not affected: 3 products
- CloudForms Management Engine 5
- Red Hat Ansible Tower 3
- Red Hat Mobile Application Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10936
- 2026-10-03 Alias added: GHSA-568q-9fw5-28wf
References
Advisory 4
Sources
- CVE-2018-10936 · CVE Program
- CVE-2018-10936 · NVD
- FIRST EPSS
- GHSA-568q-9fw5-28wf · GitHub Advisory Database · CC BY 4.0
- CVE-2018-10936 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences