Incorrect authorization in Cloud Foundry UAA
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh token will no longer be valid.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Cloud Foundry | Cloud Foundry UAA | 4.19 to before 4.19.2; 4.12 to before 4.12.4; 4.10 to before 4.10.2; 4.7 to before 4.7.6; 4.5 to before 4.5.7 | 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7 | Patch available | CNA |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | before 4.5.7 | 4.5.7 | Patch available | GHSA-r4v8-9hgx-vm6m |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.6.0 to before 4.7.6 | 4.7.6 | Patch available | GHSA-r4v8-9hgx-vm6m |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.8.0 to before 4.10.2 | 4.10.2 | Patch available | GHSA-r4v8-9hgx-vm6m |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.11.0 to before 4.12.4 | 4.12.4 | Patch available | GHSA-r4v8-9hgx-vm6m |
| — | org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) | 4.13.0 to before 4.19.2 | 4.19.2 | Patch available | GHSA-r4v8-9hgx-vm6m |
- Cloud Foundry UAA VendorCloud Foundry Affected 4.19 to before 4.19.2; 4.12 to before 4.12.4; 4.10 to before 4.10.2; 4.7 to before 4.7.6; 4.5 to before 4.5.7 Fixed in 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7 Patch available CNA
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected before 4.5.7 Fixed in 4.5.7 Patch available GHSA-r4v8-9hgx-vm6m
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.6.0 to before 4.7.6 Fixed in 4.7.6 Patch available GHSA-r4v8-9hgx-vm6m
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.8.0 to before 4.10.2 Fixed in 4.10.2 Patch available GHSA-r4v8-9hgx-vm6m
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.11.0 to before 4.12.4 Fixed in 4.12.4 Patch available GHSA-r4v8-9hgx-vm6m
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Vendor— Affected 4.13.0 to before 4.19.2 Fixed in 4.19.2 Patch available GHSA-r4v8-9hgx-vm6m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* | 4.5.0 to before 4.5.7; 4.7.0 to before 4.7.6; 4.10.0 to before 4.10.2; 4.12.0 to before 4.12.4; 4.19.0 to before 4.19.2 | Vulnerable | Spring by Pivotal |
- cpe:2.3:a:pivotal_software:cloud_foundry_uaa:*:*:*:*:*:*:*:* Versions 4.5.0 to before 4.5.7; 4.7.0 to before 4.7.6; 4.10.0 to before 4.10.2; 4.12.0 to before 4.12.4; 4.19.0 to before 4.19.2 Vulnerable ·Spring by Pivotal
Remediation
- Fix · CNA Cloud Foundry UAA (Cloud Foundry) Fixed in 4.19.2, 4.12.4, 4.10.2, 4.7.6, 4.5.7
- Fix · GHSA-r4v8-9hgx-vm6m org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.5.7 Advisory →
- Fix · GHSA-r4v8-9hgx-vm6m org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.7.6 Advisory →
- Fix · GHSA-r4v8-9hgx-vm6m org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.10.2 Advisory →
- Fix · GHSA-r4v8-9hgx-vm6m org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.12.4 Advisory →
- Fix · GHSA-r4v8-9hgx-vm6m org.cloudfoundry.identity:cloudfoundry-identity-server (Maven) Fixed in 4.19.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11047
- 2026-10-03 Alias added: GHSA-r4v8-9hgx-vm6m
References
Advisory 2
Other 12
- https://github.com/cloudfoundry/uaa/commit/0cd3c6fdd96206a1d6a376ac62e21e59e16cdcb1
- https://github.com/cloudfoundry/uaa/commit/2906057dae995024576ce6afdc20abd85569514
- https://github.com/cloudfoundry/uaa/commit/4cb1be404cf4a82e39cf2a6357aa17af8b33f2a1
- https://github.com/cloudfoundry/uaa/commit/4fa3e351ec0bface3b693810605905e29a9a8569
- https://github.com/cloudfoundry/uaa/commit/5d021e83ef143c64179d0da015aa76321ee40988
- https://github.com/cloudfoundry/uaa/commit/81aeb7a3aa048ea086c494f725d643e48dd9266
- https://github.com/cloudfoundry/uaa/commit/a1d523c7f150e56bf06df8b83ed1d416d6c1d3b
- https://github.com/cloudfoundry/uaa/commit/aba1fb5f18e0d628628b2d960fc6d0cc62d86f5
- https://github.com/cloudfoundry/uaa/commit/b37552d2bf084de059bc965b5ef5a45e64883904
- https://github.com/cloudfoundry/uaa/commit/bbbba5aec514ad88e7d1e168a2519c80229f02f
- https://github.com/cloudfoundry/uaa
- https://www.cloudfoundry.org/blog/cve-2018-11047
More Cloud Foundry vulnerabilities
- TI-2018-11240 UAA Privilege Escalation CVSS 3.0CRITICAL 9.9
- TI-2018-01169 Log Cache logs UAA client secret on startup CVSS 3.0CRITICAL 9.8
- TI-2018-07868 Cloud Foundry UAA MFA does not prevent brute force of MFA code CVSS 3.0CRITICAL 9.8
- TI-2026-18259 Cloud Foundry UAA SAML 2.0 Signature Bypass CVSS 3.1HIGH 8.6
- TI-2019-02813 Java Projects using HTTP to fetch dependencies CVSS 3.1CRITICAL 9.8
- TI-2024-24613 Authentication bypass by spoofing in Cloud Foundry haproxy-boshrelease CVSS 3.1CRITICAL 9.1
Sources
- CVE-2018-11047 · CVE Program
- CVE-2018-11047 · NVD
- FIRST EPSS
- GHSA-r4v8-9hgx-vm6m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences