TLS validation error
Priority LOW 29CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.
Why it matters now
EPSS 0.01234 69th percentileScored 2026-11-07
Fix Fixed Spring AMQP (Pivotal): 1.7.10, 2.0.6org.springframework.amqp:spring-amqp (Maven): 2.0.6, 1.7.10+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | Spring AMQP | 1.x to before 1.7.10; 2.x to before 2.0.6 | 1.7.10, 2.0.6 | Patch available | CNA |
| — | org.springframework.amqp:spring-amqp (Maven) | 2.0.0 to before 2.0.6 | 2.0.6 | Patch available | GHSA-w4g2-9hj6-5472 |
| — | org.springframework.amqp:spring-amqp (Maven) | before 1.7.10 | 1.7.10 | Patch available | GHSA-w4g2-9hj6-5472 |
| — | com.rabbitmq:amqp-client (Maven) | before 4.8.0 | 4.8.0 | Patch available | GHSA-w4g2-9hj6-5472 |
| — | com.rabbitmq:amqp-client (Maven) | 5.0.0 to before 5.4.0 | 5.4.0 | Patch available | GHSA-w4g2-9hj6-5472 |
- Spring AMQP VendorPivotal Affected 1.x to before 1.7.10; 2.x to before 2.0.6 Fixed in 1.7.10, 2.0.6 Patch available CNA
- org.springframework.amqp:spring-amqp (Maven) Vendor— Affected 2.0.0 to before 2.0.6 Fixed in 2.0.6 Patch available GHSA-w4g2-9hj6-5472
- org.springframework.amqp:spring-amqp (Maven) Vendor— Affected before 1.7.10 Fixed in 1.7.10 Patch available GHSA-w4g2-9hj6-5472
- com.rabbitmq:amqp-client (Maven) Vendor— Affected before 4.8.0 Fixed in 4.8.0 Patch available GHSA-w4g2-9hj6-5472
- com.rabbitmq:amqp-client (Maven) Vendor— Affected 5.0.0 to before 5.4.0 Fixed in 5.4.0 Patch available GHSA-w4g2-9hj6-5472
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pivotal_software:spring_advanced_message_queuing_protocol:*:*:*:*:*:*:*:* | 1.0.0 to before 1.7.10; 2.0.0 to before 2.0.6 | Vulnerable | Spring by Pivotal |
| cpe:2.3:a:vmware:rabbitmq_java_client:*:*:*:*:*:*:*:* | before 4.8.0; 4.8.1 to before 5.4.0 | Vulnerable | VMware |
- cpe:2.3:a:pivotal_software:spring_advanced_message_queuing_protocol:*:*:*:*:*:*:*:* Versions 1.0.0 to before 1.7.10; 2.0.0 to before 2.0.6 Vulnerable ·Spring by Pivotal
- cpe:2.3:a:vmware:rabbitmq_java_client:*:*:*:*:*:*:*:* Versions before 4.8.0; 4.8.1 to before 5.4.0 Vulnerable ·VMware
Remediation
- Fix · CNA Spring AMQP (Pivotal) Fixed in 1.7.10, 2.0.6
- Fix · GHSA-w4g2-9hj6-5472 org.springframework.amqp:spring-amqp (Maven) Fixed in 2.0.6 Advisory →
- Fix · GHSA-w4g2-9hj6-5472 org.springframework.amqp:spring-amqp (Maven) Fixed in 1.7.10 Advisory →
- Fix · GHSA-w4g2-9hj6-5472 com.rabbitmq:amqp-client (Maven) Fixed in 4.8.0 Advisory →
- Fix · GHSA-w4g2-9hj6-5472 com.rabbitmq:amqp-client (Maven) Fixed in 5.4.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11087
- 2026-10-03 Alias added: GHSA-w4g2-9hj6-5472
References
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-11087 · CVE Program
- CVE-2018-11087 · NVD
- FIRST EPSS
- GHSA-w4g2-9hj6-5472 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11087 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences