The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS)…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | wallabag/wallabag (Packagist) | 2.2.3 to before 2.3.3 | 2.3.3 | Patch available | GHSA-gvcw-x64m-pfcj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- wallabag/wallabag (Packagist) Vendor— Affected 2.2.3 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-gvcw-x64m-pfcj
Remediation
- Fix · GHSA-gvcw-x64m-pfcj wallabag/wallabag (Packagist) Fixed in 2.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11352
- 2026-10-03 Alias added: GHSA-gvcw-x64m-pfcj
References
More Wallabag vulnerabilities
- TI-2023-00696 Improper Authorization in wallabag/wallabag CVSS 3.1MEDIUM 5.3
- TI-2023-04113 Cross-Site Request Forgery (CSRF) in wallabag/wallabag CVSS 3.1MEDIUM 6.5
- TI-2023-00699 CSRF in wallabag/wallabag CVSS 3.1MEDIUM 6.5
- TI-2023-04112 Cross-Site Request Forgery (CSRF) in wallabag/wallabag CVSS 3.1MEDIUM 5.7
- TI-2023-00698 Cross-site Scripting (XSS) - Stored in wallabag/wallabag CVSS 3.1MEDIUM 5.4
- TI-2023-00577 Improper Authorization in wallabag/wallabag CVSS 3.1MEDIUM 4.3
Sources
- CVE-2018-11352 · CVE Program
- CVE-2018-11352 · NVD
- FIRST EPSS
- GHSA-gvcw-x64m-pfcj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences