Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.igniterealtime.openfire:parent (Maven) | before 3.9.2 | 3.9.2 | Patch available | GHSA-jphj-5g3m-w7x6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.igniterealtime.openfire:parent (Maven) Vendor— Affected before 3.9.2 Fixed in 3.9.2 Patch available GHSA-jphj-5g3m-w7x6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:igniterealtime:openfire:3.7.1:*:*:*:*:*:*:* | 3.7.1 | Vulnerable | igniterealtime |
- cpe:2.3:a:igniterealtime:openfire:3.7.1:*:*:*:*:*:*:* Versions 3.7.1 Vulnerable ·igniterealtime
Remediation
- Fix · GHSA-jphj-5g3m-w7x6 org.igniterealtime.openfire:parent (Maven) Fixed in 3.9.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11688
- 2026-10-03 Alias added: GHSA-jphj-5g3m-w7x6
References
Exploit 3
Other 4
- 20180608 Re: Ignite Realtime Openfire Version 3.7.1 Reflected Cross Site Scripting (CVE-2018-11688)
- https://github.com/igniterealtime/Openfire/compare/v3.9.1...v3.9.2
- https://github.com/igniterealtime/Openfire/commit/ed3492a24274fd454afe93a499db49f3d6335108#diff-3f607cf668ad8f1091e789a2c1dca32a
- https://github.com/igniterealtime/Openfire
More igniterealtime Openfire vulnerabilities
- TI-2023-15609 Openfire administration console authentication bypass KEVCVSS 3.1HIGH 8.6
- TI-2024-16737 An issue in Ignite Realtime Openfire v.4.9.0 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
- TI-2021-20964 An issue was discovered in Pascom Cloud Phone System before 7.20.x. CVSS 3.1CRITICAL 9.8
- TI-2008-06198 Directory traversal vulnerability in the AuthCheck filter in the Admin Console in… CVSS 2.0HIGH 7.5
- TI-2024-16736 An issue in Ignite Realtime Openfire before 4.8.1 allows a remote attacker to escalate… CVSS 3.1HIGH 7.2
- TI-2019-13396 A Server Side Request Forgery (SSRF) vulnerability in FaviconServlet.java in Ignite… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-11688 · CVE Program
- CVE-2018-11688 · NVD
- FIRST EPSS
- GHSA-jphj-5g3m-w7x6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences