Read the docs
TI-2018-08409 Aliases CVE-2018-11749GHSA-qh8x-vwrj-w4f2

Cleartext transmission of sensitive information in Puppet Enterprise

Priority MEDIUM 43CWE-319Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-319.

Summary

When users are configured to use startTLS with RBAC LDAP, at login time, the user's credentials are sent via plaintext to the LDAP server. This affects Puppet Enterprise 2018.1.3, 2017.3.9, and 2016.4.14, and is fixed in Puppet Enterprise 2018.1.4, 2017.3.10, and 2016.4.15. It scored an 8.5 CVSS score.

Why it matters now

EPSS 0.00758 55th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PuppetPuppet Enterprise2018.1.3; 2017.3.9; 2016.4.14—No fix listedCNA
  • Puppet Enterprise VendorPuppet Affected 2018.1.3; 2017.3.9; 2016.4.14 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:*up to 2016.4.14; 2017.3.0 – 2017.3.9; 2018.1.0 – 2018.1.3VulnerablePuppet
  • cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions up to 2016.4.14; 2017.3.0 – 2017.3.9; 2018.1.0 – 2018.1.3 Vulnerable ·Puppet

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-11749
  2. 2026-10-03 Alias added: GHSA-qh8x-vwrj-w4f2

References

  • TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
  • TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
  • TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
  • TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
See all 88 →

Sources