Improper certificate validation in Apache ActiveMQ
Priority MEDIUM 42CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 fixed, 4 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-295.
Summary
TLS hostname verification when using the Apache ActiveMQ Client before 5.15.6 was missing which could make the client vulnerable to a MITM attack between a Java application using the ActiveMQ client and the ActiveMQ server. This is now enabled by default.
Why it matters now
EPSS 0.06959 94th percentileScored 2026-11-07
Fix Partial org.apache.activemq:activemq-client (Maven): 5.15.6Red Hat: 1 advisoryRed Hat: 1 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache ActiveMQ | 5.0.0 - 5.15.5 | — | No fix listed | CNA |
| — | org.apache.activemq:activemq-client (Maven) | before 5.15.6 | 5.15.6 | Patch available | GHSA-m9w8-v359-9ffr |
- Apache ActiveMQ VendorApache Affected 5.0.0 - 5.15.5 Fixed in — No fix listed CNA
- org.apache.activemq:activemq-client (Maven) Vendor— Affected before 5.15.6 Fixed in 5.15.6 Patch available GHSA-m9w8-v359-9ffr
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* | before 5.15.6 | Vulnerable | Apache |
| cpe:2.3:a:oracle:enterprise_repository:12.1.3.0.0:*:*:*:*:*:*:* | 12.1.3.0.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:flexcube_private_banking:2.0.0.0:*:*:*:*:*:*:* | 2.0.0.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:flexcube_private_banking:2.2.0.1:*:*:*:*:*:*:* | 2.2.0.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:flexcube_private_banking:12.0.1.0:*:*:*:*:*:*:* | 12.0.1.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:flexcube_private_banking:12.0.3.0:*:*:*:*:*:*:* | 12.0.3.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:flexcube_private_banking:12.1.0.0:*:*:*:*:*:*:* | 12.1.0.0 | Vulnerable | Oracle |
- cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions before 5.15.6 Vulnerable ·Apache
- cpe:2.3:a:oracle:enterprise_repository:12.1.3.0.0:*:*:*:*:*:*:* Versions 12.1.3.0.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:flexcube_private_banking:2.0.0.0:*:*:*:*:*:*:* Versions 2.0.0.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:flexcube_private_banking:2.2.0.1:*:*:*:*:*:*:* Versions 2.2.0.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:flexcube_private_banking:12.0.1.0:*:*:*:*:*:*:* Versions 12.0.1.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:flexcube_private_banking:12.0.3.0:*:*:*:*:*:*:* Versions 12.0.3.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:flexcube_private_banking:12.1.0.0:*:*:*:*:*:*:* Versions 12.1.0.0 Vulnerable ·Oracle
Remediation
- Fix · GHSA-m9w8-v359-9ffr org.apache.activemq:activemq-client (Maven) Fixed in 5.15.6 Advisory →
Red Hat 1 advisory
- RHSA-2019:3892 Released 2019-11-14 · Red Hat rating ImportantRed Hat Fuse 7.5.0 security update
- Red Hat Fuse 7.5.0
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| JBoss Developer Studio 11 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss A-MQ 6 | Affected | No fix planned: Out of support scope |
| Red Hat JBoss Fuse 6 | Affected | No fix yet |
| Red Hat JBoss Fuse Service Works 6 | Affected | No fix planned: Out of support scope |
| Red Hat Fuse 7.5.0 | Fixed | RHSA-2019:3892 |
Not affected: 6 products
- Red Hat Decision Manager 7
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat Process Automation 7
- Red Hat Single Sign-On 7
- Red Hat Virtualization 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-11775
- 2026-10-03 Alias added: GHSA-m9w8-v359-9ffr
References
Patch 2
Advisory 4
Other 18
- [activemq-commits] 20190327 [CONF] Apache ActiveMQ > Security Advisories
- [activemq-dev] 20190327 Re: Website
- [activemq-commits] 20190327 svn commit: r1042639 - in /websites/production/activemq/content/activemq-website: ./ projects/artemis/download/ projects/classic/download/ projects/cms/download/ security-advisories.data/
- [activemq-dev] 20190328 Re: Website
- [activemq-commits] 20200514 [activemq-website] branch master updated: Publish CVE-2020-1941 security advisory
- https://www.oracle.com/security-alerts/cpuapr2020.html
- https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
- https://www.oracle.com/security-alerts/cpujan2021.html
- [debian-lts-announce] 20210305 [SECURITY] [DLA 2583-1] activemq security update
- https://github.com/apache/activemq/commit/02971a40e281713a8397d3a1809c164b594abfbb
- https://github.com/apache/activemq/commit/bde7097fb8173cf871827df7811b3865679b963d
- https://github.com/apache/activemq
- https://issues.apache.org/jira/browse/AMQ-7047
- https://lists.apache.org/thread.html/03f91b1fb85686a848cee6b90112cf6059bd1b21b23bacaa11a962e1@%3Cdev.activemq.apache.org%3E
- https://lists.apache.org/thread.html/2b5c0039197a4949f29e1e2c9441ab38d242946b966f61c110808bcc@%3Ccommits.activemq.apache.org%3E
- https://lists.apache.org/thread.html/a859563f05fbe7c31916b3178c2697165bd9bbf5a65d1cf62aef27d2@%3Ccommits.activemq.apache.org%3E
- https://lists.apache.org/thread.html/fcbe6ad00f1de142148c20d813fae3765dc4274955e3e2f3ca19ff7b@%3Cdev.activemq.apache.org%3E
- https://lists.apache.org/thread.html/rb698ed085f79e56146ca24ab359c9ef95846618675ea1ef402e04a6d@%3Ccommits.activemq.apache.org%3E
More Apache Activemq vulnerabilities
- TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
- TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
- TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
- TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
- TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-11775 · CVE Program
- CVE-2018-11775 · NVD
- FIRST EPSS
- GHSA-m9w8-v359-9ffr · GitHub Advisory Database · CC BY 4.0
- CVE-2018-11775 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences