In Octopus Deploy 3.0 onwards (before 2018.6.7), an authenticated user with incorrect…
Priority LOW 30CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-269.
Summary
In Octopus Deploy 3.0 onwards (before 2018.6.7), an authenticated user with incorrect permissions may be able to create Accounts under the Infrastructure menu.
Why it matters now
EPSS 0.00778 56th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:octopus:octopus_deploy:3.0:*:*:*:*:*:*:* | 3.0 | Vulnerable | Octopus Deploy |
- cpe:2.3:a:octopus:octopus_deploy:3.0:*:*:*:*:*:*:* Versions 3.0 Vulnerable ·Octopus Deploy
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-12884
- 2026-10-03 Alias added: GHSA-3469-hfcp-mxrp
References
More Octopus Deploy vulnerabilities
- TI-2020-08583 In Octopus Deploy before 2020.1.5, for customers running on-premises Active Directory… CVSS 3.1HIGH 8.8
- TI-2018-04116 An issue was discovered in Octopus Deploy before 4.1.9. CVSS 3.0HIGH 8.8
- TI-2018-03438 In Octopus Deploy versions 3.2.11 - 4.1.5 (fixed in 4.1.6), an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2017-12930 In Octopus Deploy before 4.1.3, the machine update process doesn't check that the user… CVSS 3.0HIGH 8.8
- TI-2019-08703 In Octopus Deploy 2019.1.0 through 2019.3.1 and 2019.4.0 through 2019.4.5, an… CVSS 3.0HIGH 8.1
- TI-2020-15818 In Octopus Deploy 3.1.0 to 2020.4.0, certain scripts can reveal sensitive information to the user in the task logs. CVSS 3.1HIGH 7.5
Sources
- CVE-2018-12884 · CVE Program
- CVE-2018-12884 · NVD
- FIRST EPSS
- GHSA-3469-hfcp-mxrp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences