Cross-site scripting in HackerOne m-server
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A XSS vulnerability was found in module m-server <1.4.2 that allows malicious Javascript code or HTML to be executed, due to the lack of escaping for special characters in folder names.
Why it matters now
EPSS 0.00606 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed m-server (HackerOne): 1.4.2m-server (npm): 1.4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | m-server | before 1.4.2 | 1.4.2 | Patch available | CNA |
| — | m-server (npm) | before 1.4.2 | 1.4.2 | Patch available | GHSA-gmxv-xf2q-6j8m |
- m-server VendorHackerOne Affected before 1.4.2 Fixed in 1.4.2 Patch available CNA
- m-server (npm) Vendor— Affected before 1.4.2 Fixed in 1.4.2 Patch available GHSA-gmxv-xf2q-6j8m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:m-server_project:m-server:*:*:*:*:*:node.js:*:* | before 1.4.2 | Vulnerable | M-server Project |
- cpe:2.3:a:m-server_project:m-server:*:*:*:*:*:node.js:*:* Versions before 1.4.2 Vulnerable ·M-server Project
Remediation
- Fix · CNA m-server (HackerOne) Fixed in 1.4.2
- Fix · GHSA-gmxv-xf2q-6j8m m-server (npm) Fixed in 1.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16484
- 2026-10-03 Alias added: GHSA-gmxv-xf2q-6j8m
References
More M-server Project M-server vulnerabilities
- TI-2018-11827 Path traversal in HackerOne m-server CVSS 3.0MEDIUM 6.5
Sources
- CVE-2018-16484 · CVE Program
- CVE-2018-16484 · NVD
- FIRST EPSS
- GHSA-gmxv-xf2q-6j8m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences