Path traversal in HackerOne m-server
Priority LOW 32CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Path Traversal vulnerability in module m-server <1.4.1 allows malicious user to access unauthorized content of any file in the directory tree e.g. /etc/passwd by appending slashes to the URL request.
Why it matters now
EPSS 0.01333 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed m-server (HackerOne): 1.4.1m-server (npm): 1.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | m-server | before 1.4.1 | 1.4.1 | Patch available | CNA |
| — | m-server (npm) | before 1.4.1 | 1.4.1 | Patch available | GHSA-899g-6q6w-7v94 |
- m-server VendorHackerOne Affected before 1.4.1 Fixed in 1.4.1 Patch available CNA
- m-server (npm) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-899g-6q6w-7v94
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:m-server_project:m-server:*:*:*:*:*:node.js:*:* | before 1.4.1 | Vulnerable | M-server Project |
- cpe:2.3:a:m-server_project:m-server:*:*:*:*:*:node.js:*:* Versions before 1.4.1 Vulnerable ·M-server Project
Remediation
- Fix · CNA m-server (HackerOne) Fixed in 1.4.1
- Fix · GHSA-899g-6q6w-7v94 m-server (npm) Fixed in 1.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16485
- 2026-10-03 Alias added: GHSA-899g-6q6w-7v94
References
More M-server Project M-server vulnerabilities
- TI-2018-11826 Cross-site scripting in HackerOne m-server CVSS 3.0MEDIUM 5.4
Sources
- CVE-2018-16485 · CVE Program
- CVE-2018-16485 · NVD
- FIRST EPSS
- GHSA-899g-6q6w-7v94 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences