Read the docs
TI-2018-12785 Aliases CVE-2018-17960GHSA-g68x-vvqq-pvw3

CKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste.

Priority LOW 31CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

CKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste.

Why it matters now

EPSS 0.01946 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ckeditor (npm): 4.11.0typo3/cms-core (Packagist): 8.7.21, 9.5.2+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ckeditor (npm)before 4.11.04.11.0Patch availableGHSA-g68x-vvqq-pvw3
—typo3/cms-core (Packagist)8.0.0 to before 8.7.218.7.21Patch availableGHSA-g68x-vvqq-pvw3
—typo3/cms-core (Packagist)9.0.0 to before 9.5.29.5.2Patch availableGHSA-g68x-vvqq-pvw3
—typo3/cms (Packagist)8.0.0 to before 8.7.218.7.21Patch availableGHSA-g68x-vvqq-pvw3
—typo3/cms (Packagist)9.0.0 to before 9.5.29.5.2Patch availableGHSA-g68x-vvqq-pvw3
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ckeditor (npm) Vendor— Affected before 4.11.0 Fixed in 4.11.0 Patch available GHSA-g68x-vvqq-pvw3
  • typo3/cms-core (Packagist) Vendor— Affected 8.0.0 to before 8.7.21 Fixed in 8.7.21 Patch available GHSA-g68x-vvqq-pvw3
  • typo3/cms-core (Packagist) Vendor— Affected 9.0.0 to before 9.5.2 Fixed in 9.5.2 Patch available GHSA-g68x-vvqq-pvw3
  • typo3/cms (Packagist) Vendor— Affected 8.0.0 to before 8.7.21 Fixed in 8.7.21 Patch available GHSA-g68x-vvqq-pvw3
  • typo3/cms (Packagist) Vendor— Affected 9.0.0 to before 9.5.2 Fixed in 9.5.2 Patch available GHSA-g68x-vvqq-pvw3

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:*:*:*:*4.0 to before 4.11.0Vulnerableckeditor
  • cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:*:*:*:* Versions 4.0 to before 4.11.0 Vulnerable ·ckeditor

Remediation

  • Fix · GHSA-g68x-vvqq-pvw3 ckeditor (npm) Fixed in 4.11.0 Advisory →
  • Fix · GHSA-g68x-vvqq-pvw3 typo3/cms-core (Packagist) Fixed in 8.7.21 Advisory →
  • Fix · GHSA-g68x-vvqq-pvw3 typo3/cms-core (Packagist) Fixed in 9.5.2 Advisory →
  • Fix · GHSA-g68x-vvqq-pvw3 typo3/cms (Packagist) Fixed in 8.7.21 Advisory →
  • Fix · GHSA-g68x-vvqq-pvw3 typo3/cms (Packagist) Fixed in 9.5.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-17960
  2. 2026-10-03 Alias added: GHSA-g68x-vvqq-pvw3

References

  • TI-2023-15111 A unrestricted file upload vulnerability was discovered in the ‘Browse and upload images’… CVSS 3.1CRITICAL 9.8
  • TI-2021-18004 HTML comments vulnerability allowing to execute JavaScript code CVSS 3.1HIGH 8.2
  • TI-2022-08543 Regular expression Denial of Service in dialog plugin CVSS 3.1HIGH 7.5
  • TI-2021-18003 Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML CVSS 3.1HIGH 8.2
  • TI-2021-12473 Cross-site scripting in ckeditor via abuse of undo functionality CVSS 3.1HIGH 7.6
  • TI-2011-04280 Information disclosure in CKSource CKEditor Drupal module CVSS 3.1HIGH 7.5
See all 23 →

Sources