Priority HIGH 82
A unrestricted file upload vulnerability was discovered in the ‘Browse and upload images’ feature of the CKEditor v1.2.3 plugin for Redmine, which allows arbitrary files to be uploaded to the server.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01431 · Published 2023-06-13 · No fix listed CWE-434
Priority LOW 39
CKEditor4 is an open source WYSIWYG HTML editor.
CVSS 3.1HIGH 8.2· Network · Low privileges · User interaction · EPSS 0.01573 · Published 2021-11-17 · Fixed in 4.17.0 CWE-79
Priority LOW 38
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02487 · Published 2022-03-16 · Fixed in 4.18.0 CWE-400
Priority LOW 38
CKEditor4 is an open source WYSIWYG HTML editor.
CVSS 3.1HIGH 8.2· Network · Low privileges · User interaction · EPSS 0.01346 · Published 2021-11-17 · Fixed in 4.17.0 CWE-79
Priority LOW 36
ckeditor is an open source WYSIWYG HTML editor with rich content support.
CVSS 3.1HIGH 7.6· Network · Low privileges · User interaction · EPSS 0.01192 · Published 2021-08-12 · Fixed in 4.16.2 CWE-79
Priority LOW 36
hook_file_download in the CKEditor module 7.x-1.4 for Drupal does not properly restrict access to private files, which allows remote attackers to read private files via a direct request.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01744 · Published 2019-11-13 · No fix listed CWE-200
Priority LOW 35
ckeditor is an open source WYSIWYG HTML editor with rich content support.
CVSS 3.1HIGH 7.3· Network · Low privileges · User interaction · EPSS 0.01318 · Published 2021-08-12 · Fixed in 4.16.2 CWE-79
Priority LOW 34
A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected synt…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.04308 · Published 2020-03-07 · Fixed in 4.14.0 CWE-79
Priority LOW 33
A cross-site scripting (XSS) vulnerability in the HTML Data Processor in CKEditor 4 4.14.0 through 4.16.x before 4.16.1 allows remote attackers to inject executable JavaScript code through a crafted comment because --!>…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.03189 · Published 2021-06-09 · Fixed in 4.16.1, 7.80 +3 CWE-79
Priority LOW 33
It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted URL-like text into the editor, and then press Enter or Space (in the Autolink plugin).
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.0235 · Published 2021-01-26 · Fixed in 4.16.0 CWE-829
Priority LOW 33
It was possible to execute a ReDoS-type attack inside CKEditor 4 before 4.16 by persuading a victim to paste crafted text into the Styles input of specific dialogs (in the Advanced Tab for Dialogs plugin).
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.01994 · Published 2021-01-26 · Fixed in 4.16 CWE-829
Priority LOW 33
Unspecified vulnerability in the CKeditor module 6.x-2.x before 6.x-2.3 and the CKEditor module 6.x-1.x before 6.x-1.9 and 7.x-1.x before 7.x-1.7 for Drupal, when the core PHP module is enabled, allows remote authenticat…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.0153 · Published 2012-09-05 · No fix listed
Priority LOW 31
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01652 · Published 2024-02-07 · Fixed in 4.24.0-lts CWE-79
Priority LOW 31
CKSource CKEditor 5 35.4.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the Full Featured CKEditor5 widget.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.02097 · Published 2023-02-13 · No fix listed CWE-79
Priority LOW 31
A cross-site scripting (XSS) vulnerability in the Color Dialog plugin for CKEditor 4.15.0 allows remote attackers to run arbitrary web script after persuading a user to copy and paste crafted HTML code into one of editor…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0205 · Published 2020-11-12 · Fixed in 4.15.1 CWE-79
Priority LOW 31
CKEditor 4.x before 4.11.0 allows user-assisted XSS involving a source-mode paste.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01946 · Published 2018-11-14 · Fixed in 4.11.0, 8.7.21 +1 CWE-79
Priority LOW 30
A cross-site scripting (XSS) vulnerability in the WSC plugin through 5.5.7.5 for CKEditor 4 allows remote attackers to run arbitrary web script inside an IFRAME element by injecting a crafted HTML element into the editor…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0131 · Published 2020-03-10 · No fix listed CWE-79
Priority LOW 28
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0045 · Published 2024-08-21 · Fixed in 4.25.0-lts, 4.25.0 CWE-79
Priority LOW 28
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00706 · Published 2024-02-07 · Fixed in 4.24.0-lts, 4.24.0 CWE-79
Priority LOW 28
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00725 · Published 2023-03-22 · Fixed in 4.21.0 CWE-79
Priority LOW 27
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01203 · Published 2022-03-16 · Fixed in 4.18.0 CWE-79
Priority LOW 27
ckeditor is an open source WYSIWYG HTML editor with rich content support.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01188 · Published 2021-08-12 · Fixed in 4.16.2 CWE-94
Priority LOW 24
Cross-site scripting (XSS) vulnerability in the Preview plugin before 4.4.3 in CKEditor allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01834 · Published 2014-08-07 · Fixed in 4.4.3 CWE-79
Priority LOW 23
Cross-site scripting (XSS) vulnerability in the FCKeditor module 6.x-2.x before 6.x-2.3 and the CKEditor module 6.x-1.x before 6.x-1.9 and 7.x-1.x before 7.x-1.7 for Drupal allows remote authenticated users or remote att…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01357 · Published 2012-09-05 · No fix listed CWE-79