Read the docs
TI-2018-13680 Aliases CVE-2018-19296GHSA-7w4p-72j7-v7c2

PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.

Priority MEDIUM 42CWE-1321Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution, Tampering
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502 and CWE-915.

Summary

PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.

Why it matters now

EPSS 0.02229 82nd percentileScored 2026-11-07
Fix Fixed phpmailer/phpmailer (Packagist): 5.2.27, 6.0.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmailer/phpmailer (Packagist)5.0.0 to before 5.2.275.2.27Patch availableGHSA-7w4p-72j7-v7c2
—phpmailer/phpmailer (Packagist)6.0.0 to before 6.0.66.0.6Patch availableGHSA-7w4p-72j7-v7c2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmailer/phpmailer (Packagist) Vendor— Affected 5.0.0 to before 5.2.27 Fixed in 5.2.27 Patch available GHSA-7w4p-72j7-v7c2
  • phpmailer/phpmailer (Packagist) Vendor— Affected 6.0.0 to before 6.0.6 Fixed in 6.0.6 Patch available GHSA-7w4p-72j7-v7c2

CPE configurations NVD · 6

CPEVersionsRoleVendor
cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:*before 5.2.27; 6.0.0 to before 6.0.6VulnerablePhpmailer Project
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:*33VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:*34VulnerableFedoraproject
cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*3.7 – 5.7VulnerableWordPress
  • cpe:2.3:a:phpmailer_project:phpmailer:*:*:*:*:*:*:*:* Versions before 5.2.27; 6.0.0 to before 6.0.6 Vulnerable ·Phpmailer Project
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
  • cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:* Versions 3.7 – 5.7 Vulnerable ·WordPress

Remediation

  • Fix · GHSA-7w4p-72j7-v7c2 phpmailer/phpmailer (Packagist) Fixed in 5.2.27 Advisory →
  • Fix · GHSA-7w4p-72j7-v7c2 phpmailer/phpmailer (Packagist) Fixed in 6.0.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-19296
  2. 2026-10-03 Alias added: GHSA-7w4p-72j7-v7c2

References

Sources