Read the docs
TI-2018-14145 Aliases CVE-2018-19957GHSA-fcwx-wvr2-2xm2

Insufficient HTTP Security Headers in QTS, QuTS hero, and QuTScloud

Priority LOW 28CWE-1021Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-1021.

Summary

A vulnerability involving insufficient HTTP security headers has been reported to affect QNAP NAS running QTS, QuTS hero, and QuTScloud. This vulnerability allows remote attackers to launch privacy and security attacks. We have already fixed this vulnerability in the following versions: QTS 4.5.4.1715 build 20210630 and later QuTS hero h4.5.4.1771 build 20210825 and later QuTScloud c4.5.6.1755 build 20210809 and later

Why it matters now

EPSS 0.00707 53rd percentileScored 2026-11-07
Fix Fixed QTS (QNAP Systems Inc.): 4.5.4.1715 build 20210630QuTS hero (QNAP Systems Inc.): h4.5.4.1771 build 20210825+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
QNAPQTSbefore 4.5.4.1715 build 202106304.5.4.1715 build 20210630Patch availableCNA
QNAPQuTS herobefore h4.5.4.1771 build 20210825h4.5.4.1771 build 20210825Patch availableCNA
QNAPQuTScloudbefore c4.5.6.1755 build 20210809c4.5.6.1755 build 20210809Patch availableCNA
  • QTS VendorQNAP Affected before 4.5.4.1715 build 20210630 Fixed in 4.5.4.1715 build 20210630 Patch available CNA
  • QuTS hero VendorQNAP Affected before h4.5.4.1771 build 20210825 Fixed in h4.5.4.1771 build 20210825 Patch available CNA
  • QuTScloud VendorQNAP Affected before c4.5.6.1755 build 20210809 Fixed in c4.5.6.1755 build 20210809 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:*before 4.5.4.1715VulnerableQNAP
cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:*before h4.5.4.1771VulnerableQNAP
cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:*before c4.5.6.1755VulnerableQNAP
  • cpe:2.3:o:qnap:qts:*:*:*:*:*:*:*:* Versions before 4.5.4.1715 Vulnerable ·QNAP
  • cpe:2.3:o:qnap:quts_hero:*:*:*:*:*:*:*:* Versions before h4.5.4.1771 Vulnerable ·QNAP
  • cpe:2.3:o:qnap:qutscloud:*:*:*:*:*:*:*:* Versions before c4.5.6.1755 Vulnerable ·QNAP

Remediation

  • Fix · CNA QTS (QNAP Systems Inc.) Fixed in 4.5.4.1715 build 20210630
  • Fix · CNA QuTS hero (QNAP Systems Inc.) Fixed in h4.5.4.1771 build 20210825
  • Fix · CNA QuTScloud (QNAP Systems Inc.) Fixed in c4.5.6.1755 build 20210809

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    QNAP Systems QuTS hero h4.5.4.1771 build 20210825

    3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW

    Other records, highest priority first

    • TI-2021-09807 Stack Buffer Overflow Vulnerabilities in QTS, QuTS hero, and QuTScloudPriority MEDIUM 40
    • TI-2021-13385 Buffer Overflow Vulnerability in QTS, QuTS hero, and QuTScloudPriority LOW 36

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-19957
  2. 2026-10-03 Alias added: GHSA-fcwx-wvr2-2xm2

References

  • TI-2020-02221 Command Injection Vulnerability in QTS and QuTS hero KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-05101 Improper input validation in QNAP NAS devices KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-14137 Improper input validation in QNAP QTS KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
  • TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-14131 Cross-site scripting in QNAP QTS KEVCVSS 3.1HIGH 8.0
See all 282 →

Sources