An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | before 4.8.4 | 4.8.4 | Patch available | GHSA-xc97-r49q-cxgc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected before 4.8.4 Fixed in 4.8.4 Patch available GHSA-xc97-r49q-cxgc
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* | 4.0.0 to before 4.8.4 | Vulnerable | phpMyAdmin |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.8.4 Vulnerable ·phpMyAdmin
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-xc97-r49q-cxgc phpmyadmin/phpmyadmin (Packagist) Fixed in 4.8.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-19968
- 2026-10-03 Alias added: GHSA-xc97-r49q-cxgc
References
Advisory 3
Sources
- CVE-2018-19968 · CVE Program
- CVE-2018-19968 · NVD
- FIRST EPSS
- GHSA-xc97-r49q-cxgc · GitHub Advisory Database · CC BY 4.0
- CVE-2018-19968 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences